Code

check_host: Allocate a large-enough buffer for the host table.
[nagiosplug.git] / plugins-scripts / Makefile.am
index 6656881db07710b3eb3cf311a7d207bbda583e70..58db06048ec0c0e6f62b956bffbde0019f88e15e 100644 (file)
@@ -1,5 +1,14 @@
 ## Process this file with automake to produce Makefile.in
 
+if RELEASE_PRESENT
+NP_VERSION = @NP_RELEASE@
+else
+NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
+       @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
+.FORCE-NP-VERSION-FILE:
+-include NP-VERSION-FILE
+endif
+
 SUFFIXES = .pl .sh
 
 VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t
@@ -22,12 +31,20 @@ test:
        perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
        perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t   # utils.t is excluded from above, so manually ask to test
 
+test-debug:
+       NPTEST_DEBUG=1 HARNESS_VERBOSE=1 perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
+       NPTEST_DEBUG=1 HARNESS_VERBOSE=1 perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t  # utils.t is excluded from above, so manually ask to test
+
 CLEANFILES=$(libexec_SCRIPTS)
 
 .pl :
-       $(AWK) -f ./subst $< > $@
+       NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
        chmod +x $@
 
 .sh :
-       $(AWK) -f ./subst $< > $@
+       NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
        chmod +x $@
+
+clean-local:
+       rm -f NP-VERSION-FILE
+