Code

check_host: Allocate a large-enough buffer for the host table.
[nagiosplug.git] / plugins-scripts / Makefile.am
index 5556cf696a723bdeaf54a0ce0bdfead1df88cadd..58db06048ec0c0e6f62b956bffbde0019f88e15e 100644 (file)
@@ -1,11 +1,20 @@
 ## Process this file with automake to produce Makefile.in
 
+if RELEASE_PRESENT
+NP_VERSION = @NP_RELEASE@
+else
+NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
+       @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
+.FORCE-NP-VERSION-FILE:
+-include NP-VERSION-FILE
+endif
+
 SUFFIXES = .pl .sh
 
 VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t
 
 libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \
-       check_log check_ntp check_oracle check_rpc check_sensors check_wave \
+       check_log check_oracle check_rpc check_sensors check_wave \
        check_ifstatus check_ifoperstatus check_mailq check_file_age \
        utils.sh utils.pm
 
@@ -20,15 +29,22 @@ TESTS = @SCRIPT_TEST@
 
 test:
        perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
+       perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t   # utils.t is excluded from above, so manually ask to test
 
-CLEANFILES=$(libexec_SCRIPTS)
+test-debug:
+       NPTEST_DEBUG=1 HARNESS_VERBOSE=1 perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
+       NPTEST_DEBUG=1 HARNESS_VERBOSE=1 perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t  # utils.t is excluded from above, so manually ask to test
 
-AM_INSTALL_PROGRAM_FLAGS=@INSTALL_OPTS@
+CLEANFILES=$(libexec_SCRIPTS)
 
 .pl :
-       $(AWK) -f ./subst $< > $@
+       NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
        chmod +x $@
 
 .sh :
-       $(AWK) -f ./subst $< > $@
+       NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@
        chmod +x $@
+
+clean-local:
+       rm -f NP-VERSION-FILE
+