Code

check_host: Allocate a large-enough buffer for the host table.
[nagiosplug.git] / plugins-scripts / Makefile.am
index 19702739d7d1db9968c30613adf1fef26cebeedb..58db06048ec0c0e6f62b956bffbde0019f88e15e 100644 (file)
@@ -1,13 +1,13 @@
 ## Process this file with automake to produce Makefile.in
 
+if RELEASE_PRESENT
+NP_VERSION = @NP_RELEASE@
+else
 NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
        @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
 .FORCE-NP-VERSION-FILE:
-
-## This is undocumented and could possibly break in future versions of
-## automake. See:
-## http://article.gmane.org/gmane.comp.sysutils.automake.general/10036
-@am__include@ @am__quote@NP-VERSION-FILE@am__quote@
+-include NP-VERSION-FILE
+endif
 
 SUFFIXES = .pl .sh
 
@@ -27,8 +27,6 @@ TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
 
 TESTS = @SCRIPT_TEST@
 
-all-local: NP-VERSION-FILE
-
 test:
        perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
        perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t   # utils.t is excluded from above, so manually ask to test