Code

Removing CVS/SVN tags and replacing with git-based versioning
[nagiosplug.git] / plugins-root / Makefile.am
index 107d9933d2e828418d8744c17eb231b2daa6b66e..de8813ffe052531327c454023e5c2896cbf4dd06 100644 (file)
@@ -1,5 +1,11 @@
 ## Process this file with automake to produce Makefile.in
 
+NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
+       @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
+-include NP-VERSION-FILE
+
+AM_CFLAGS = -DNP_VERSION='"$(NP_VERSION)"'
+
 VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir)
 
 INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@
@@ -74,3 +80,10 @@ pst3_LDFLAGS = @PST3CFLAGS@
 
 check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS) 
 check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS)
+
+all-local: .FORCE-NP-VERSION-FILE
+
+clean-local:
+       rm -f NP-VERSION-FILE
+
+.PHONY: .FORCE-NP-VERSION-FILE