Code

Added state retention APIs. Implemented for check_snmp with --rate option.
[nagiosplug.git] / lib / Makefile.am
index b9383083ea962891e9eb51bb542f6b888924934a..99fa591aeb95d450976ea912d70605e3643661dd 100644 (file)
@@ -1,17 +1,20 @@
 ## Process this file with automake to produce Makefile.in
 
+SUBDIRS = . tests
+
 noinst_LIBRARIES = libnagiosplug.a
 
-libnagiosplug_a_SOURCES = getopt.c getopt1.c snprintf.c fsusage.c mountlist.c xmalloc.c
+AM_CPPFLAGS = -DNP_STATE_DIR_PREFIX=\"$(localstatedir)\"
+
+libnagiosplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c
+EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h
+
+if USE_PARSE_INI
+libnagiosplug_a_SOURCES += parse_ini.c extra_opts.c
+endif USE_PARSE_INI
 
-libnagiosplug_a_LIBADD = @LIBOBJS@
-libnagiosplug_a_DEPENDENCIES = $(libnagiosplug_a_LIBADD)
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
 
-# Extra GNU libraries required if target is missing these functions
-EXTRA_DIST = ulonglong.m4 codeset.m4 getloadavg.m4 gettext.m4 glibc21.m4 iconv.m4 intdiv0.m4 \
-               inttypes.m4 inttypes_h.m4 inttypes-pri.m4 isc-posix.m4 lcmessage.m4 lib-ld.m4 \
-               lib-link.m4 lib-prefix.m4 progtest.m4 stdint_h.m4 uintmax_t.m4 afs.m4 \
-               fstypename.m4 fsusage.m4 ls-mntd-fs.m4 getopt.h gettext.h fsusage.h mountlist.h\
-               error.m4 error.h error.c xalloc.h unlocked-io.h malloc.c realloc.c strtod.c
+test test-debug:
+       cd tests && make $@
 
-INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl