Code

Fix for regex input of '|', being output causing problems with Nagios' parsing of
[nagiosplug.git] / lib / Makefile.am
index 9cab14af87e513a35159cde7432009f49c7e867e..99fa591aeb95d450976ea912d70605e3643661dd 100644 (file)
@@ -1,46 +1,20 @@
 ## Process this file with automake to produce Makefile.in
 
-noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
-
-# Will auto pick up fsusage.c mountlist.c
-libcoreutils_a_SOURCES = \
-  cloexec.c cloexec.h \
-  exit.h \
-  exitfail.c exitfail.h \
-  fsusage.h \
-  full-read.c full-read.h \
-  full-write.c full-write.h \
-  getopt.c getopt.h getopt1.c \
-  gettext.h \
-  mountlist.h \
-  safe-read.c safe-read.h \
-  safe-write.c safe-write.h \
-  unlocked-io.h \
-  xalloc.h \
-  xmalloc.c \
-  xstrdup.c
-
-other_coreutils_files = \
-  error.c error.h \
-  fsusage.c \
-  getloadaavg.c \
-  malloc.c \
-  mountlist.c \
-  realloc.c \
-  strtod.c
-
-libcoreutils_a_LIBADD = $(LIBOBJS)
-libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
-
-libnagiosplug_a_SOURCES = snprintf.c
-
-INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
-
-BUILT_SOURCES = $(STDBOOL_H)
-EXTRA_DIST = stdbool_.h
-MOSTLYCLEANFILES = stdbool.h stdbool.ht
-# Create stdbool.h on systems that lack a working one.
-stdbool.h: stdbool_.h
-       sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
-       mv $@t $@
+SUBDIRS = . tests
+
+noinst_LIBRARIES = libnagiosplug.a
+
+AM_CPPFLAGS = -DNP_STATE_DIR_PREFIX=\"$(localstatedir)\"
+
+libnagiosplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c
+EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h
+
+if USE_PARSE_INI
+libnagiosplug_a_SOURCES += parse_ini.c extra_opts.c
+endif USE_PARSE_INI
+
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
+
+test test-debug:
+       cd tests && make $@