Code

Added state retention APIs. Implemented for check_snmp with --rate option.
[nagiosplug.git] / lib / Makefile.am
index 7826a28691714fd47a0c9affdcf899a5c868c3a5..99fa591aeb95d450976ea912d70605e3643661dd 100644 (file)
@@ -1,11 +1,20 @@
 ## Process this file with automake to produce Makefile.in
 
+SUBDIRS = . tests
+
 noinst_LIBRARIES = libnagiosplug.a
 
-noinst_HEADERS = getopt.h getaddrinfo.h gethostbyname.h
+AM_CPPFLAGS = -DNP_STATE_DIR_PREFIX=\"$(localstatedir)\"
+
+libnagiosplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c
+EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h
+
+if USE_PARSE_INI
+libnagiosplug_a_SOURCES += parse_ini.c extra_opts.c
+endif USE_PARSE_INI
 
-libnagiosplug_a_SOURCES = getopt.c getopt1.c getloadavg.c
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
 
-INCLUDES = -I$(srcdir)
+test test-debug:
+       cd tests && make $@
 
-EXTRA_DIST = getaddrinfo.c gethostbyname.c