Code

- Add --enable-extra-opts configure option for compiling extra-opts support
[nagiosplug.git] / lib / Makefile.am
index 5d65bed639fb24ff68b2bec93be84abac1431842..73c12911e1ab34351e54897d6010cde42e208d47 100644 (file)
@@ -6,7 +6,11 @@ noinst_LIBRARIES = libnagiosplug.a
 
 
 libnagiosplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c
-EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h
+EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h
+
+if USE_PARSE_INI
+libnagiosplug_a_SOURCES += parse_ini.c extra_opts.c
+endif USE_PARSE_INI
 
 INCLUDES = -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins