Code

ab29f95e8ed16fcc6c63ff3a9015ee2a31c83132
[gosa.git] / gosa-core / debian / patches / 05_fix_online_help_location.patch
1 Author: <cajus@debian.org>
2 Description: Fix location of auto-generated online help.
3 --- a/html/helpviewer.php
4 +++ b/gosa-core/html/helpviewer.php
5 @@ -104,7 +104,7 @@
6  if(session::global_is_set('current_class_for_help')){
7  
8    /* Create new XML parser with the path to the Xml file */
9 -  $xml = new parseXml("../doc/guide.xml");
10 +  $xml = new parseXml("/etc/gosa/guide.xml");
11    
12    /* Generate help array */
13    $str = $xml->parse();
14 --- a/update-gosa
15 +++ b/gosa-core/update-gosa
16 @@ -195,7 +195,7 @@
17  
18  function rescan_guide()
19  {
20 -       $master_guide= "doc/guide.xml";
21 +       $master_guide= "/etc/gosa/guide.xml";
22         echo "Updating Online Help Index...\n";
23         $master_guide_content="<?xml version=\"1.0\"?>\n".
24                 "<!--\n".