Code

Install "NEWS" and "CHANGES" into all packages.
[pkg-rrdtool.git] / debian / rules
index 685669fec3d0a7a40a3b5f6e98dc6f7326fa329c..e213bf1360fcf29fea1f196bcbd43f813cf81b50 100755 (executable)
@@ -4,18 +4,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-Makefile.am:librrd_la_LDFLAGS         = -version-info 2:12:0
-Makefile.am:librrd_th_la_LDFLAGS         = $(MULTITHREAD_LDFLAGS) -version-info 2:11:0
-
+#we use quilt
+include /usr/share/quilt/quilt.make
 
 
 #library versions
 LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,:,.,g')
+               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
 LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-LIB_TH_version := $(shell grep '^librrd_th_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,:,.,g')
-LIB_major := $(shell echo $(LIB_th_version) | sed 's,\..*,,g')
 
 
 
@@ -29,6 +25,10 @@ PY_VERS := $(shell set -e; \
                        if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
                    done)
 
+#tcl version we're building for
+TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+
+
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -45,23 +45,30 @@ CONFFLAGS += --disable-python --disable-ruby
 CONFFLAGS += --prefix=/usr --docdir=/usr/share/doc/rrdtool
 
 #install perl libs in vendor mode
-CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor
-
+CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor 
 
+#path to our ttf font
+CONFFLAGS += --with-rrd-default-font=/usr/share/rrdtool/librrd$(LIB_major)/DejaVuSansMono-Roman.ttf
 
+#path to tcl
+CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
 #let's take care of optimization + debug builds
 CFLAGS += -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
+#don't optimize on arm for now - #447041
+ifneq ($(DEB_HOST_GNU_TYPE), arm)
         CFLAGS += -O2
 endif
+endif
 
-LDFLAGS="-Wl,-z,defs"
+# work-around for a broken dpkg - do not rename this to LDFLAGS :-/
+LINKER_FLAGS=-Wl,-z,defs
 
 configure: config.status
-config.status:
+config.status: $(QUILT_STAMPFN)
 
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -70,7 +77,7 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
-       LDFLAGS="$(LDFLAGS)"
+       LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
          ./configure $(CONFFLAGS)
@@ -82,16 +89,21 @@ build-arch-stamp: config.status
 
        #configure forgets to set TCL_INC_DIR.
        make TCL_INC_DIR=/usr/include/tcl
+       #Fix library path to tcl bindings
+       sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
        touch $@
 
 build-python%: build-arch-stamp
-       cd bindings/python && env BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build
+       set -e ;\
+        cd bindings/python ;\
+        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build
        touch $@
 
-build-indep: build-indep-stamp
-build-indep-stamp: config.status
+build-indep: build-arch-stamp
+       #indep stuff is built in build-arch-stamp, too.
 
-clean: $(PY_VERS:%=clean-python%)
+clean: clean-patched
+clean-patched: unpatch $(PY_VERS:%=clean-python%)
        dh_testdir
        dh_testroot
        #sanity check if debian/control lists the right package name
@@ -105,7 +117,7 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        rm -f config.guess
 endif
-       rm -f build-arch-stamp build-indep-stamp config.status
+       rm -f build-arch-stamp build-indep-stamp config.status install-common-stamp
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
@@ -114,31 +126,33 @@ endif
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
+       rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
 
        dh_clean
 
-clean-python%:
-       cd bindings/python && python$* setup.py clean
+clean-python%: unpatch
+       set -e ;\
+        cd bindings/python ;\
+        python$* setup.py clean
        rm -f build-python$*
 
-install: install-indep install-arch
-install-indep:
-       dh_testdir
-       dh_testroot
-       dh_clean -k -s
-       dh_installdirs -s
 
+install: install-arch install-indep
 
-       dh_install -s
+install-indep: build-indep install-common-stamp
+       #nothing to do
 
-install-arch: $(PY_VERS:%=install-python%)
+install-common-stamp: build-arch-stamp
        dh_testdir
        dh_testroot
-       dh_clean -k -s
-       dh_installdirs -s
+       dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
 
+       touch $@
+
+install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        #build and install ruby
        set -e; \
        cd bindings/ruby ;\
@@ -150,37 +164,42 @@ install-arch: $(PY_VERS:%=install-python%)
          make distclean ;\
        done
 
-       dh_install -s --sourcedir=$(CURDIR)/debian/tmp
        dh_installexamples -s
 
-install-python%:
-       cd bindings/python && python$* setup.py install --root=$(CURDIR)/debian/python-rrd
+install-python%: install-common-stamp
+       dh_testdir
+       dh_testroot
+       set -e ;\
+        cd bindings/python ;\
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool
 
 
-binary-indep:
+binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
-       echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
        dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_installchangelogs
-       dh_installdocs -s -Nlibrrd-ruby
-       dh_link -s -Nlibrrd-ruby
-       dh_perl -s
-       dh_compress -s
-       dh_fixperms -s
-       dh_installdeb -s
-       dh_gencontrol -s
-       dh_md5sums -s
-       dh_builddeb -s
+       dh_link -ppython-rrd /usr/share/doc/python-rrdtool /usr/share/doc/python-rrd
+       dh_installchangelogs -i -Nlibrrd-ruby -Npython-rrd CHANGES
+       dh_installdocs -i -Nlibrrd-ruby -Npython-rrd -A CONTRIBUTORS NEWS
+       dh_link -i -Nlibrrd-ruby -Npython-rrd
+       echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
+       dh_perl -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
        
 
 binary-arch: build-arch install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a CHANGES
+       dh_installdocs -a -A CONTRIBUTORS NEWS
        dh_installdocs -a
-#      dh_installexamples -a
-       dh_pysupport -ppython-rrd
+       echo 'tcl:Depends=tcl$(TCL_VERS) | tclsh' >> debian/rrdtool-tcl.substvars
+       dh_pysupport -ppython-rrdtool
        dh_perl -a
        dh_installman -a
        dh_link -a
@@ -198,5 +217,5 @@ binary-arch: build-arch install-arch
 binary: binary-arch binary-indep
 .PHONY: build clean configure \
         binary-indep binary-arch binary \
-        install install-arch install-indep \
-        install-python% clean-python%
+        install install-arch \
+        install-python% clean-python% unpatch