Code

rules: Use $(DPATCH_STAMPFN) rather than "patch".
[pkg-fusedav.git] / debian / rules
index 274855d83e93b3d66c5831a07e4114b117037584..d0c619bcbaefdddc2f53bbc1f60eefc0eef6ef70 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for fusedav
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -15,13 +15,15 @@ CFLAGS = -Wall -g
 
 BUILDDIR = ./debian/build/
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
-$(BUILDDIR)/config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+$(BUILDDIR)/config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
@@ -38,7 +40,7 @@ build-stamp: $(BUILDDIR)/config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp