Code

rules: Use 'pyversions -vr' instead of 'pysupport-parseversions'.
[pkg-rrdtool.git] / debian / rules
index e213bf1360fcf29fea1f196bcbd43f813cf81b50..cce2ae287370bd2420d7ad5d2a8dac9508b802a3 100755 (executable)
@@ -8,25 +8,15 @@
 include /usr/share/quilt/quilt.make
 
 
-#library versions
-LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-
-
-
 #Ruby versions to build for
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
 
-#Python versions to build for. The work-around-doko way.
-PY_VERS := $(shell set -e; \
-                   for py in `pysupport-parseversions debian/pyversions`; do \
-                       if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
-                   done)
+PY_VERS := $(shell pyversions -vr)
 
 #tcl version we're building for
-TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
+       | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
 
 #let's help configure to figure out our host/build system
@@ -47,9 +37,6 @@ CONFFLAGS += --prefix=/usr --docdir=/usr/share/doc/rrdtool
 #install perl libs in vendor mode
 CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor 
 
-#path to our ttf font
-CONFFLAGS += --with-rrd-default-font=/usr/share/rrdtool/librrd$(LIB_major)/DejaVuSansMono-Roman.ttf
-
 #path to tcl
 CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
@@ -86,11 +73,14 @@ build: build-arch build-indep
 
 build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
 build-arch-stamp: config.status 
-
-       #configure forgets to set TCL_INC_DIR.
-       make TCL_INC_DIR=/usr/include/tcl
+       make
        #Fix library path to tcl bindings
        sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
+       #sanity check if debian/control lists the right package name
+       LIB_major=`grep '^dlname=' src/librrd.la \
+                       | sed -e "s/^dlname='librrd\.so\.\\([0-9]\+\\)'\$$/\\1/"` \
+               && test -n "$$LIB_major" \
+               && grep -q "^Package: librrd$$LIB_major\\>" debian/control
        touch $@
 
 build-python%: build-arch-stamp
@@ -106,8 +96,6 @@ clean: clean-patched
 clean-patched: unpatch $(PY_VERS:%=clean-python%)
        dh_testdir
        dh_testroot
-       #sanity check if debian/control lists the right package name
-       grep -q '^Package: librrd$(LIB_major)' debian/control
 
        [ ! -f Makefile ] || make distclean
 
@@ -121,12 +109,14 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
+       rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean
 
@@ -148,7 +138,9 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
+       # we don't want .txt and .pod documentation in the package
+       rm -rf debian/tmp/usr/share/doc/rrdtool/txt
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
 
        touch $@
 
@@ -203,7 +195,7 @@ binary-arch: build-arch install-arch
        dh_perl -a
        dh_installman -a
        dh_link -a
-       dh_strip -a
+       dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
        dh_makeshlibs -a