Code

rules: Use 'pyversions -vr' instead of 'pysupport-parseversions'.
[pkg-rrdtool.git] / debian / rules
index da426047eaa7974eee934ce9101f44a5e2fd0336..cce2ae287370bd2420d7ad5d2a8dac9508b802a3 100755 (executable)
@@ -12,14 +12,11 @@ include /usr/share/quilt/quilt.make
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
 
-#Python versions to build for. The work-around-doko way.
-PY_VERS := $(shell set -e; \
-                   for py in `pysupport-parseversions debian/pyversions`; do \
-                       if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
-                   done)
+PY_VERS := $(shell pyversions -vr)
 
 #tcl version we're building for
-TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
+       | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
 
 #let's help configure to figure out our host/build system
@@ -76,9 +73,7 @@ build: build-arch build-indep
 
 build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
 build-arch-stamp: config.status 
-
-       #configure forgets to set TCL_INC_DIR.
-       make TCL_INC_DIR=/usr/include/tcl
+       make
        #Fix library path to tcl bindings
        sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
        #sanity check if debian/control lists the right package name
@@ -114,13 +109,14 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean
 
@@ -142,7 +138,9 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
+       # we don't want .txt and .pod documentation in the package
+       rm -rf debian/tmp/usr/share/doc/rrdtool/txt
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
 
        touch $@
 
@@ -197,7 +195,7 @@ binary-arch: build-arch install-arch
        dh_perl -a
        dh_installman -a
        dh_link -a
-       dh_strip -a
+       dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
        dh_makeshlibs -a