Code

control: Moved librrd-ruby* packages to section "ruby".
[pkg-rrdtool.git] / debian / rules
index d642464cef1dab1303a48ea254c2f81191b4816f..9f220d3849aae662787b464e1694527886eabb2f 100755 (executable)
@@ -113,13 +113,14 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean
 
@@ -141,6 +142,8 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
+       # we don't want .txt and .pod documentation in the package
+       rm -rf debian/tmp/usr/share/doc/rrdtool/txt
        dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
 
        touch $@
@@ -196,7 +199,7 @@ binary-arch: build-arch install-arch
        dh_perl -a
        dh_installman -a
        dh_link -a
-       dh_strip -a
+       dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
        dh_makeshlibs -a