Code

Closing #428780.
[pkg-rrdtool.git] / debian / rules
index cca0d82f1ebdc1aabacfd817c09ef38dd55a6aea..9e196a7bad96863492d7e10cd1e727c37a28aa2f 100755 (executable)
@@ -8,13 +8,6 @@
 include /usr/share/quilt/quilt.make
 
 
-#library versions
-LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-
-
-
 #Ruby versions to build for
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
@@ -83,11 +76,14 @@ build: build-arch build-indep
 
 build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
 build-arch-stamp: config.status 
-
-       #configure forgets to set TCL_INC_DIR.
-       make TCL_INC_DIR=/usr/include/tcl
+       make
        #Fix library path to tcl bindings
        sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
+       #sanity check if debian/control lists the right package name
+       LIB_major=`grep '^dlname=' src/librrd.la \
+                       | sed -e "s/^dlname='librrd\.so\.\\([0-9]\+\\)'\$$/\\1/"` \
+               && test -n "$$LIB_major" \
+               && grep -q "^Package: librrd$$LIB_major\\>" debian/control
        touch $@
 
 build-python%: build-arch-stamp
@@ -103,8 +99,6 @@ clean: clean-patched
 clean-patched: unpatch $(PY_VERS:%=clean-python%)
        dh_testdir
        dh_testroot
-       #sanity check if debian/control lists the right package name
-       grep -q '^Package: librrd$(LIB_major)' debian/control
 
        [ ! -f Makefile ] || make distclean