Code

Updating changelog.
[pkg-rrdtool.git] / debian / rules
index d642464cef1dab1303a48ea254c2f81191b4816f..996f23ce56d79cd11310ddb22cde23a7f52c9db1 100755 (executable)
@@ -7,16 +7,23 @@
 #we use quilt
 include /usr/share/quilt/quilt.make
 
+#needed to build with Python 2.6
+-include /usr/share/python/python.mk
+ifeq (,$(py_sitename))
+  py_sitename = site-packages
+  py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
+  py_sitename_sh = $(py_sitename)
+  py_libdir_sh = $(py_libdir)
+  py_setup_install_args = 
+endif
+
+
 
 #Ruby versions to build for
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
 
-#Python versions to build for. The work-around-doko way.
-PY_VERS := $(shell set -e; \
-                   for py in `pysupport-parseversions debian/pyversions`; do \
-                       if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
-                   done)
+PY_VERS := $(shell pyversions -vr)
 
 #tcl version we're building for
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
@@ -75,7 +82,7 @@ endif
 
 build: build-arch build-indep 
 
-build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
+build-arch: build-arch-stamp $(PY_VERS:%=build-python%) $(PY_VERS:%=build-python%-dbg)
 build-arch-stamp: config.status 
        make
        #Fix library path to tcl bindings
@@ -90,14 +97,14 @@ build-arch-stamp: config.status
 build-python%: build-arch-stamp
        set -e ;\
         cd bindings/python ;\
-        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build
-       touch $@
+        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build ;\
+        touch $@
 
 build-indep: build-arch-stamp
        #indep stuff is built in build-arch-stamp, too.
 
 clean: clean-patched
-clean-patched: unpatch $(PY_VERS:%=clean-python%)
+clean-patched: unpatch $(PY_VERS:%=clean-python%) $(PY_VERS:%=clean-python%-dbg)
        dh_testdir
        dh_testroot
 
@@ -113,21 +120,22 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean
 
 clean-python%: unpatch
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py clean
-       rm -f build-python$*
+        python$* setup.py clean ;\
+        rm -f build-python$*
 
 
 install: install-arch install-indep
@@ -141,7 +149,9 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
+       # we don't want .txt and .pod documentation in the package
+       rm -rf debian/tmp/usr/share/doc/rrdtool/txt
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
 
        touch $@
 
@@ -164,17 +174,22 @@ install-python%: install-common-stamp
        dh_testroot
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool \
+               $(py_setup_install_args) ;\
+        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg \
+               $(py_setup_install_args)
+
+       find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
+                xargs -0r rm -f
 
 
 binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
        dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_link -ppython-rrd /usr/share/doc/python-rrdtool /usr/share/doc/python-rrd
-       dh_installchangelogs -i -Nlibrrd-ruby -Npython-rrd CHANGES
-       dh_installdocs -i -Nlibrrd-ruby -Npython-rrd -A CONTRIBUTORS NEWS
-       dh_link -i -Nlibrrd-ruby -Npython-rrd
+       dh_installchangelogs -i -Nlibrrd-ruby CHANGES
+       dh_installdocs -i -Nlibrrd-ruby -A CONTRIBUTORS NEWS
+       dh_link -i -Nlibrrd-ruby
        echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
        dh_perl -i
        dh_compress -i
@@ -193,10 +208,11 @@ binary-arch: build-arch install-arch
        dh_installdocs -a
        echo 'tcl:Depends=tcl$(TCL_VERS) | tclsh' >> debian/rrdtool-tcl.substvars
        dh_pysupport -ppython-rrdtool
+       dh_pysupport -prrdtool-dbg
        dh_perl -a
        dh_installman -a
        dh_link -a
-       dh_strip -a
+       dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
        dh_makeshlibs -a