Code

debian/rules: Remove src/librrd.sym in the clean target.
[pkg-rrdtool.git] / debian / rules
index cca0d82f1ebdc1aabacfd817c09ef38dd55a6aea..809c70399e46f36946e811188ac0ebdcb4a41802 100755 (executable)
@@ -8,13 +8,6 @@
 include /usr/share/quilt/quilt.make
 
 
-#library versions
-LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-
-
-
 #Ruby versions to build for
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
@@ -26,7 +19,8 @@ PY_VERS := $(shell set -e; \
                    done)
 
 #tcl version we're building for
-TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
+       | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
 
 #let's help configure to figure out our host/build system
@@ -83,11 +77,14 @@ build: build-arch build-indep
 
 build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
 build-arch-stamp: config.status 
-
-       #configure forgets to set TCL_INC_DIR.
-       make TCL_INC_DIR=/usr/include/tcl
+       make
        #Fix library path to tcl bindings
        sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
+       #sanity check if debian/control lists the right package name
+       LIB_major=`grep '^dlname=' src/librrd.la \
+                       | sed -e "s/^dlname='librrd\.so\.\\([0-9]\+\\)'\$$/\\1/"` \
+               && test -n "$$LIB_major" \
+               && grep -q "^Package: librrd$$LIB_major\\>" debian/control
        touch $@
 
 build-python%: build-arch-stamp
@@ -103,8 +100,6 @@ clean: clean-patched
 clean-patched: unpatch $(PY_VERS:%=clean-python%)
        dh_testdir
        dh_testroot
-       #sanity check if debian/control lists the right package name
-       grep -q '^Package: librrd$(LIB_major)' debian/control
 
        [ ! -f Makefile ] || make distclean
 
@@ -118,13 +113,14 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean