Code

patches: Reintroduced compiler-warning-fixes updated for 1.4.
[pkg-rrdtool.git] / debian / rules
index 4918fbe6756c5a8259e696af373aaee1e65d70b6..7cac8f60b4ade2f57fcdffd3fdb3d8908854795d 100755 (executable)
@@ -22,6 +22,8 @@ TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_ARCH_CPU   ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
   CONFFLAGS += --build $(DEB_HOST_GNU_TYPE)
 else
@@ -46,7 +48,7 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
 #don't optimize on arm for now - #447041
-ifneq ($(DEB_HOST_GNU_TYPE), arm)
+ifneq ($(DEB_HOST_ARCH_CPU), arm)
         CFLAGS += -O2
 endif
 endif
@@ -87,13 +89,13 @@ build-python%: build-arch-stamp
        set -e ;\
         cd bindings/python ;\
         BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build ;\
-       touch $@
+        touch $@
 
 build-indep: build-arch-stamp
        #indep stuff is built in build-arch-stamp, too.
 
 clean: clean-patched
-clean-patched: unpatch $(PY_VERS:%=clean-python%)
+clean-patched: unpatch $(PY_VERS:%=clean-python%) $(PY_VERS:%=clean-python%-dbg)
        dh_testdir
        dh_testroot
 
@@ -117,14 +119,15 @@ endif
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
        rm -f src/librrd.sym
+       rm -f config.h
 
        dh_clean
 
 clean-python%: unpatch
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py clean
-       rm -f build-python$*
+        python$* setup.py clean ;\
+        rm -f build-python$*
 
 
 install: install-arch install-indep
@@ -157,6 +160,7 @@ install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        done
 
        dh_installexamples -s
+       chmod 644 debian/rrdtool/usr/share/doc/rrdtool/examples/rrdcached/RRDCached.pm
 
 install-python%: install-common-stamp
        dh_testdir
@@ -165,16 +169,17 @@ install-python%: install-common-stamp
         cd bindings/python ;\
         python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool ;\
         python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg
+       find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
+                xargs -0r rm -f
 
 
 binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
        dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_link -ppython-rrd /usr/share/doc/python-rrdtool /usr/share/doc/python-rrd
-       dh_installchangelogs -i -Nlibrrd-ruby -Npython-rrd CHANGES
-       dh_installdocs -i -Nlibrrd-ruby -Npython-rrd -A CONTRIBUTORS NEWS
-       dh_link -i -Nlibrrd-ruby -Npython-rrd
+       dh_installchangelogs -i -Nlibrrd-ruby CHANGES
+       dh_installdocs -i -Nlibrrd-ruby -A CONTRIBUTORS NEWS
+       dh_link -i -Nlibrrd-ruby
        echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
        dh_perl -i
        dh_compress -i