Code

Add fixed path for tcllib
[pkg-rrdtool.git] / debian / rules
index 679934a177982a95abddb270e9d14b421bd2454f..4be5bfa6d23ef3af1a436dd9b8117f7227341f49 100755 (executable)
@@ -10,11 +10,8 @@ include /usr/share/quilt/quilt.make
 
 #library versions
 LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
+               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
 LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-LIB_TH_version := $(shell grep '^librrd_th_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_TH_major := $(shell echo $(LIB_TH_version) | sed 's,\..*,,g')
 
 
 
@@ -29,8 +26,8 @@ PY_VERS := $(shell set -e; \
                    done)
 
 #tcl version we're building for
-TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
-
+#TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+TCL_VERS := 8.4
 
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -53,16 +50,22 @@ CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor
 #path to our ttf font
 CONFFLAGS += --with-rrd-default-font=/usr/share/rrdtool/librrd$(LIB_major)/DejaVuSansMono-Roman.ttf
 
+#path to tcl
+CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
 #let's take care of optimization + debug builds
 CFLAGS += -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
+#don't optimize on arm for now - #447041
+ifneq ($(DEB_HOST_GNU_TYPE), arm)
         CFLAGS += -O2
 endif
+endif
 
-LDFLAGS="-Wl,-z,defs"
+# work-around for a broken dpkg - do not rename this to LDFLAGS :-/
+LINKER_FLAGS=-Wl,-z,defs
 
 configure: config.status
 config.status: $(QUILT_STAMPFN)
@@ -74,7 +77,7 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
-       LDFLAGS="$(LDFLAGS)"
+       LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
          ./configure $(CONFFLAGS)
@@ -145,7 +148,7 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
 
        touch $@
 
@@ -199,10 +202,6 @@ binary-arch: build-arch install-arch
        dh_pysupport -ppython-rrdtool
        dh_perl -a
        dh_installman -a
-       dh_link -plibrrd2-dev /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so
-       dh_link -plibrrd2-dev /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so.$(LIB_major)
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so.$(LIB_TH_major)
        dh_link -a
        dh_strip -a
        dh_compress -a