Code

debian/patches/implicit-decl-fix:
[pkg-rrdtool.git] / debian / rules
index e2a2694847bae9ed6c892229d1eef617ded42e00..4171e2bb79e1d93a04f4b5706daeedb8eb07d384 100755 (executable)
@@ -10,11 +10,8 @@ include /usr/share/quilt/quilt.make
 
 #library versions
 LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
+               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
 LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-LIB_TH_version := $(shell grep '^librrd_th_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_TH_major := $(shell echo $(LIB_TH_version) | sed 's,\..*,,g')
 
 
 
@@ -28,6 +25,10 @@ PY_VERS := $(shell set -e; \
                        if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
                    done)
 
+#tcl version we're building for
+#TCL_VERS := $(shell dpkg -s tcl | grep ^Depends | sed 's,.*tcl\([0-9.]*\).*,\1,')
+TCL_VERS := 8.4
+
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -44,20 +45,27 @@ CONFFLAGS += --disable-python --disable-ruby
 CONFFLAGS += --prefix=/usr --docdir=/usr/share/doc/rrdtool
 
 #install perl libs in vendor mode
-CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor
-
+CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor 
 
+#path to our ttf font
+CONFFLAGS += --with-rrd-default-font=/usr/share/rrdtool/librrd$(LIB_major)/DejaVuSansMono-Roman.ttf
 
+#path to tcl
+CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
 #let's take care of optimization + debug builds
 CFLAGS += -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
+#don't optimize on arm for now - #447041
+ifneq ($(DEB_HOST_GNU_TYPE), arm)
         CFLAGS += -O2
 endif
+endif
 
-LDFLAGS="-Wl,-z,defs"
+# work-around for a broken dpkg - do not rename this to LDFLAGS :-/
+LINKER_FLAGS=-Wl,-z,defs
 
 configure: config.status
 config.status: $(QUILT_STAMPFN)
@@ -69,7 +77,7 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
-       LDFLAGS="$(LDFLAGS)"
+       LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
          ./configure $(CONFFLAGS)
@@ -80,7 +88,7 @@ build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
 build-arch-stamp: config.status 
 
        #configure forgets to set TCL_INC_DIR.
-       make TCL_INC_DIR=/usr/include/tcl
+       make TCL_INC_DIR=/usr/include/tcl8.4
        #Fix library path to tcl bindings
        sed -i -e 's|lib/|lib/tcltk/rrdtool-tcl/|' bindings/tcl/pkgIndex.tcl
        touch $@
@@ -118,6 +126,7 @@ endif
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
+       rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
 
        dh_clean
 
@@ -139,7 +148,7 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
 
        touch $@
 
@@ -169,11 +178,10 @@ binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
        dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_link -plibrrd2-dev /usr/share/doc/librrd-dev /usr/share/doc/librrd2-dev
        dh_link -ppython-rrd /usr/share/doc/python-rrdtool /usr/share/doc/python-rrd
-       dh_installchangelogs -i -Nlibrrd-ruby -Nlibrrd2-dev -Npython-rrd
-       dh_installdocs -i -Nlibrrd-ruby -Nlibrrd2-dev -Npython-rrd
-       dh_link -i -Nlibrrd-ruby -Nlibrrd2-dev -Npython-rrd
+       dh_installchangelogs -i -Nlibrrd-ruby -Npython-rrd
+       dh_installdocs -i -Nlibrrd-ruby -Npython-rrd -A CONTRIBUTORS
+       dh_link -i -Nlibrrd-ruby -Npython-rrd
        echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
        dh_perl -i
        dh_compress -i
@@ -188,15 +196,12 @@ binary-arch: build-arch install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a CHANGES
+       dh_installdocs -a -A CONTRIBUTORS
        dh_installdocs -a
-#      dh_installexamples -a
+       echo 'tcl:Depends=tcl$(TCL_VERS) | tclsh' >> debian/rrdtool-tcl.substvars
        dh_pysupport -ppython-rrdtool
        dh_perl -a
        dh_installman -a
-       dh_link -plibrrd-dev /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so
-       dh_link -plibrrd-dev /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so.$(LIB_major)
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so.$(LIB_TH_major)
        dh_link -a
        dh_strip -a
        dh_compress -a