Code

No longer conflict / replace librrd0 and librrd0-dev.
[pkg-rrdtool.git] / debian / rules
index d871649b2b39a2edee28793143ab7e21771844fb..27220867a86a3aba4919be8ada8bffdb8d4ff336 100755 (executable)
@@ -10,11 +10,8 @@ include /usr/share/quilt/quilt.make
 
 #library versions
 LIB_version := $(shell grep '^librrd_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
+               sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
 LIB_major := $(shell echo $(LIB_version) | sed 's,\..*,,g')
-LIB_TH_version := $(shell grep '^librrd_th_la_LDFLAGS' src/Makefile.am | \
-                           sed 's,^[^0-9]*,,g;s,\([0-9]*\):\([0-9]*\):\([0-9]*\),\1.\3.\2,g')
-LIB_TH_major := $(shell echo $(LIB_TH_version) | sed 's,\..*,,g')
 
 
 
@@ -50,17 +47,25 @@ CONFFLAGS += --prefix=/usr --docdir=/usr/share/doc/rrdtool
 #install perl libs in vendor mode
 CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor 
 
+#path to our ttf font
+CONFFLAGS += --with-rrd-default-font=/usr/share/rrdtool/librrd$(LIB_major)/DejaVuSansMono-Roman.ttf
 
+#path to tcl
+CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
 #let's take care of optimization + debug builds
 CFLAGS += -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
+#don't optimize on arm for now - #447041
+ifneq ($(DEB_HOST_GNU_TYPE), arm)
         CFLAGS += -O2
 endif
+endif
 
-LDFLAGS="-Wl,-z,defs"
+# work-around for a broken dpkg - do not rename this to LDFLAGS :-/
+LINKER_FLAGS=-Wl,-z,defs
 
 configure: config.status
 config.status: $(QUILT_STAMPFN)
@@ -72,7 +77,7 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
-       LDFLAGS="$(LDFLAGS)"
+       LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
          ./configure $(CONFFLAGS)
@@ -121,6 +126,7 @@ endif
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
+       rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
 
        dh_clean
 
@@ -142,7 +148,7 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
 
        touch $@
 
@@ -196,10 +202,6 @@ binary-arch: build-arch install-arch
        dh_pysupport -ppython-rrdtool
        dh_perl -a
        dh_installman -a
-       dh_link -plibrrd2-dev /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so
-       dh_link -plibrrd2-dev /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd.so.$(LIB_version) /usr/lib/librrd.so.$(LIB_major)
-       dh_link -plibrrd$(LIB_major) /usr/lib/librrd_th.so.$(LIB_TH_version) /usr/lib/librrd_th.so.$(LIB_TH_major)
        dh_link -a
        dh_strip -a
        dh_compress -a