Code

Build Python dbg modules into rrdtool-dbg.
[pkg-rrdtool.git] / debian / rules
index d642464cef1dab1303a48ea254c2f81191b4816f..209a1ff11bec20a89fc07c8b8e24462082a8a5da 100755 (executable)
@@ -12,11 +12,7 @@ include /usr/share/quilt/quilt.make
 RUBY_VERS := 1.8 1.9
 RUBY_DEFAULT_VERS := 1.8
 
-#Python versions to build for. The work-around-doko way.
-PY_VERS := $(shell set -e; \
-                   for py in `pysupport-parseversions debian/pyversions`; do \
-                       if [ -x /usr/bin/python$$py ]; then echo $$py; fi;    \
-                   done)
+PY_VERS := $(shell pyversions -vr)
 
 #tcl version we're building for
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
@@ -75,7 +71,7 @@ endif
 
 build: build-arch build-indep 
 
-build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
+build-arch: build-arch-stamp $(PY_VERS:%=build-python%) $(PY_VERS:%=build-python%-dbg)
 build-arch-stamp: config.status 
        make
        #Fix library path to tcl bindings
@@ -90,7 +86,7 @@ build-arch-stamp: config.status
 build-python%: build-arch-stamp
        set -e ;\
         cd bindings/python ;\
-        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build
+        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build ;\
        touch $@
 
 build-indep: build-arch-stamp
@@ -113,13 +109,14 @@ endif
        find . -name \*.pyc | xargs rm -f
        rm -rf bindings/python/build
 
-       #clean what the Makefiles do not clean....
+       # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
               bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
+       rm -f src/librrd.sym
 
        dh_clean
 
@@ -141,7 +138,9 @@ install-common-stamp: build-arch-stamp
        dh_clean -k
 
        make install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --list-missing
+       # we don't want .txt and .pod documentation in the package
+       rm -rf debian/tmp/usr/share/doc/rrdtool/txt
+       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
 
        touch $@
 
@@ -164,7 +163,8 @@ install-python%: install-common-stamp
        dh_testroot
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool ;\
+        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg
 
 
 binary-indep: build-indep install-indep
@@ -196,7 +196,7 @@ binary-arch: build-arch install-arch
        dh_perl -a
        dh_installman -a
        dh_link -a
-       dh_strip -a
+       dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
        dh_makeshlibs -a