Code

debian/rules: Remove NEWS.html and README.html in the clean target.
[pkg-tig.git] / debian / rules
index f76af1df1704b7e17d1e78aa5b6a33d28cfe4994..1ddab6c2835aa08917a972ce6f222e3dc40fff73 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/make -f
-# debian/ruls for tig
+# debian/rules for tig
 #
 # Written by Sebastian Harl <sh@tokkee.org>
 
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,22 +19,24 @@ else
        CFLAGS += -O2
 endif
 
+include /usr/share/dpatch/dpatch.make
+
 config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)" LIBS="-lncursesw"
+               CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
-build-stamp: config.status
+build-stamp: config.status $(DPATCH_STAMPFN)
        dh_testdir
        
        $(MAKE) all doc
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -44,6 +46,8 @@ clean:
        rm -f config.h config.log config.make config.status
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
+       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -66,7 +70,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
-       dh_installdocs BUGS TODO manual.pdf
+       dh_installdocs NEWS BUGS TODO manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip