Code

debian/rules: Remove NEWS.html and README.html in the clean target.
[pkg-tig.git] / debian / rules
index ec84d33719f356a117c9c5bf0abd17396f6c2777..1ddab6c2835aa08917a972ce6f222e3dc40fff73 100755 (executable)
@@ -1,11 +1,16 @@
 #!/usr/bin/make -f
-# debian/ruls for tig
+# debian/rules for tig
 #
 # Written by Sebastian Harl <sh@tokkee.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -14,21 +19,35 @@ else
        CFLAGS += -O2
 endif
 
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure
+       dh_testdir
+       ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+               --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
+               CFLAGS="$(CFLAGS)"
+
 build: build-stamp
 
-build-stamp:
+build-stamp: config.status $(DPATCH_STAMPFN)
        dh_testdir
        
-       CFLAGS="$(FLAGS)" $(MAKE) all doc
+       $(MAKE) all doc
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
        
-       -$(MAKE) clean
+       $(MAKE) clean
+       
+       rm -f config.h config.log config.make config.status
+       rm -rf manual.html-chunked/
+       rm -f manual.pdf manual.html manual.toc
+       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -38,8 +57,7 @@ install: build
        dh_clean -k
        dh_installdirs
        
-       $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig \
-                       prefix=/usr mandir=/usr/share/man
+       $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
        
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
@@ -52,7 +70,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
-       dh_installdocs BUGS TODO manual.pdf
+       dh_installdocs NEWS BUGS TODO manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip