Code

plugin: Make sdb_plugin_info_t public.
[sysdb.git] / t / Makefile.am
index bfeadcfc13d7cab9485c6ae20eaa310b99f46e1e..5de153f16e5718cd9c316c5077dabb8ea5b54868 100644 (file)
@@ -2,7 +2,8 @@ EXTRA_DIST = \
                coverage.sh \
                integration/simple_config.sh \
                integration/simple_query.sh \
-               integration/test_lib.sh
+               integration/test_lib.sh \
+               valgrind.suppress
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
@@ -11,7 +12,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
 TESTS =
 check_PROGRAMS =
-noinst_LTLIBRARIES =
+check_LTLIBRARIES =
 
 #
 # unit tests
@@ -36,6 +37,7 @@ unit_libsysdb_test_SOURCES = \
                unit/utils/channel_test.c \
                unit/utils/dbi_test.c \
                unit/utils/llist_test.c \
+               unit/utils/os_test.c \
                unit/utils/strbuf_test.c
 unit_libsysdb_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
@@ -57,7 +59,7 @@ if INTEGRATION_TESTING
 TESTS += integration/simple_config.sh integration/simple_query.sh
 endif
 
-noinst_LTLIBRARIES += integration/mock_plugin.la
+check_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
 # -rpath is a work-around to enforce a shared library
 integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \