Code

Split the memstore module from the store module.
[sysdb.git] / src / Makefile.am
index f3bcae192846276a26dfbd868ba946868d5cbc19..886cc1ad2d80d562db0bba0fe71d141bb9518c9a 100644 (file)
@@ -72,16 +72,16 @@ libsysdb_fe_parser_la_CFLAGS = @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@ \
                -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\""
 libsysdb_la_SOURCES = \
                sysdb.c include/sysdb.h \
+               core/data.c include/core/data.h \
+               core/memstore.c include/core/memstore.h \
+               core/memstore-private.h \
+               core/memstore_exec.c \
+               core/memstore_expr.c \
+               core/memstore_lookup.c \
+               core/memstore_query.c \
                core/object.c include/core/object.h \
                core/plugin.c include/core/plugin.h \
-               core/store.c include/core/store.h \
-               core/store-private.h \
-               core/store_exec.c \
-               core/store_expr.c \
-               core/store_json.c \
-               core/store_lookup.c \
-               core/store_query.c \
-               core/data.c include/core/data.h \
+               core/store_json.c include/core/store.h \
                core/time.c include/core/time.h \
                core/timeseries.c include/core/timeseries.h \
                frontend/connection.c include/frontend/connection.h \