Code

Do not ignore "make clean" errors.
[pkg-pfstools.git] / debian / rules
index e5963bbfee44beb9bd3d31081546641f7e8796cc..e775717e4c62224c8c99179c8192a5ba87f08ff4 100755 (executable)
@@ -51,8 +51,8 @@ clean:
        dh_testroot
        rm -f build-stamp 
        
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
        for file in config.guess config.sub; do \
                if [ -e $$file.upstream ]; then \