Code

Added libpfs-dbg binary package.
[pkg-pfstools.git] / debian / rules
index e5963bbfee44beb9bd3d31081546641f7e8796cc..df6bacf06592194cfbc16a8038304356cbfaf74a 100755 (executable)
@@ -34,6 +34,7 @@ config.status: configure
        CXXFLAGS="$(CXXFLAGS)" ./configure \
                        --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr --mandir=\$${prefix}/share/man \
+                       --with-moc=moc-qt3 \
                        --with-octave-m-dir=$(MDIR)/pfstools \
                        --with-octave-oct-dir=$(OCTDIR)/pfstools
 
@@ -51,8 +52,8 @@ clean:
        dh_testroot
        rm -f build-stamp 
        
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
        for file in config.guess config.sub; do \
                if [ -e $$file.upstream ]; then \
@@ -88,8 +89,11 @@ binary-arch: build install
        dh_install --sourcedir=debian/tmp --list-missing
        dh_installman debian/pfsglview.1
        dh_link
-       dh_strip
-       dh_compress
+       dh_strip --dbg-package=pfstools-dbg
+       # mkoctfile removes any symbol table and relocation information from the
+       # .oct files making them unusable for the -dbg package
+       rm -rf debian/pfstools-dbg/usr/lib/debug/usr/lib/octave/
+       dh_compress -X.pdf
        dh_fixperms
        dh_makeshlibs
        dh_installdeb