Code

Switched to octave3.0.
[pkg-pfstools.git] / debian / rules
index fb8a7bf34568841186df2b7e4af88ed79cf5b072..d0d84b26af533f99dec2a1378ea374cbbcbcc073 100755 (executable)
@@ -20,8 +20,9 @@ else
 endif
 
 include /usr/share/octave/debian/defs.make
+include /usr/share/dpatch/dpatch.make
 
-config.status: configure
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
        for file in config.guess config.sub; do \
@@ -47,7 +48,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp 
@@ -72,7 +73,7 @@ install: build
        
        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
        
-       chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
+       chmod 644 debian/tmp/$(MDIR)/pfstools/*
        
        # these binaries are not available
        rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1