Code

rules: Use dh_install's --fail-missing instead of --list-missing.
[pkg-pfstools.git] / debian / rules
index cd793efb7395a4b82ebede1b02dcc1f99f130f5b..98b76b92d7b422926e0aa0acfbff33ad7e216da4 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for pfstools
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -73,7 +73,7 @@ install: build
        
        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
        
-       chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
+       chmod 644 debian/tmp/$(MDIR)/pfstools/*
        
        # these binaries are not available
        rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
@@ -85,14 +85,15 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs ChangeLog
-       dh_installdocs AUTHORS README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs -A AUTHORS
        dh_installexamples
-       dh_install --sourcedir=debian/tmp --list-missing
-       # these files have been installed twice
+       dh_install --sourcedir=debian/tmp --fail-missing
+       # these files have been installed twice by dh_install
        rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
                debian/pfstools/usr/share/man/man1/pfsv.1 \
                debian/pfstools/usr/share/man/man1/pfs*view.1
-       dh_installman -ppfsglview debian/pfsglview.1
+       dh_installman
        dh_link
        dh_strip --dbg-package=pfstools-dbg
        # mkoctfile removes any symbol table and relocation information from the