Code

Updated to new upstream release 1.6.4.
[pkg-pfstools.git] / debian / rules
index e5963bbfee44beb9bd3d31081546641f7e8796cc..84752e94a5b582a759594084f3d9053bbe4d13ef 100755 (executable)
@@ -34,6 +34,7 @@ config.status: configure
        CXXFLAGS="$(CXXFLAGS)" ./configure \
                        --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr --mandir=\$${prefix}/share/man \
+                       --with-moc=moc-qt3 \
                        --with-octave-m-dir=$(MDIR)/pfstools \
                        --with-octave-oct-dir=$(OCTDIR)/pfstools
 
@@ -51,8 +52,8 @@ clean:
        dh_testroot
        rm -f build-stamp 
        
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
        for file in config.guess config.sub; do \
                if [ -e $$file.upstream ]; then \
@@ -74,7 +75,7 @@ install: build
        chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
        
        # these binaries are not available
-       rm debian/tmp/usr/share/man/man1/pfs{in,out}jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
 
 binary-indep: build install
        # nothing to do here
@@ -86,10 +87,17 @@ binary-arch: build install
        dh_installdocs AUTHORS README TODO doc/faq.txt doc/pfs_format_spec.pdf
        dh_installexamples
        dh_install --sourcedir=debian/tmp --list-missing
-       dh_installman debian/pfsglview.1
+       # these files have been installed twice
+       rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
+               debian/pfstools/usr/share/man/man1/pfsv.1 \
+               debian/pfstools/usr/share/man/man1/pfs*view.1
+       dh_installman -ppfsglview debian/pfsglview.1
        dh_link
-       dh_strip
-       dh_compress
+       dh_strip --dbg-package=pfstools-dbg
+       # mkoctfile removes any symbol table and relocation information from the
+       # .oct files making them unusable for the -dbg package
+       rm -rf debian/pfstools-dbg/usr/lib/debug/usr/lib/octave/
+       dh_compress -X.pdf
        dh_fixperms
        dh_makeshlibs
        dh_installdeb