Code

control, rules: Use ${octave:Depends} and octave3.0-depends.
[pkg-pfstools.git] / debian / rules
index c2acab0b51b1b3d864963ced997b3465111e1209..4f9c2e5895f385409b8a16b0ff29ff09d40f12c0 100755 (executable)
@@ -88,7 +88,7 @@ binary-arch: build install
        dh_installdocs README TODO doc/faq.txt doc/pfs_format_spec.pdf
        dh_installdocs -A AUTHORS
        dh_installexamples
-       dh_install --sourcedir=debian/tmp --list-missing
+       dh_install --sourcedir=debian/tmp --fail-missing
        # these files have been installed twice by dh_install
        rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
                debian/pfstools/usr/share/man/man1/pfsv.1 \
@@ -104,6 +104,7 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps -Llibpfs-1.2-0 -ldebian/libpfs-1.2-0/usr/lib/
+       octave3.0-depends -poctave-pfstools
        dh_gencontrol
        dh_md5sums
        dh_builddeb