Code

rules: Remove pfsingdal.1 from the package.
[pkg-pfstools.git] / debian / rules
index fb8a7bf34568841186df2b7e4af88ed79cf5b072..155719e0ed0e86e895a53d04a73269b15240f1a7 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for pfstools
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -20,8 +20,9 @@ else
 endif
 
 include /usr/share/octave/debian/defs.make
+include /usr/share/dpatch/dpatch.make
 
-config.status: configure
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
        for file in config.guess config.sub; do \
@@ -47,7 +48,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp 
@@ -72,10 +73,11 @@ install: build
        
        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
        
-       chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
+       chmod 644 debian/tmp/$(MDIR)/pfstools/*
        
        # these binaries are not available
        rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfsingdal.1
 
 binary-indep: build install
        # nothing to do here
@@ -87,12 +89,12 @@ binary-arch: build install
        dh_installdocs README TODO doc/faq.txt doc/pfs_format_spec.pdf
        dh_installdocs -A AUTHORS
        dh_installexamples
-       dh_install --sourcedir=debian/tmp --list-missing
-       # these files have been installed twice
+       dh_install --sourcedir=debian/tmp --fail-missing
+       # these files have been installed twice by dh_install
        rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
                debian/pfstools/usr/share/man/man1/pfsv.1 \
                debian/pfstools/usr/share/man/man1/pfs*view.1
-       dh_installman -ppfsglview debian/pfsglview.1
+       dh_installman
        dh_link
        dh_strip --dbg-package=pfstools-dbg
        # mkoctfile removes any symbol table and relocation information from the
@@ -103,6 +105,7 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps -Llibpfs-1.2-0 -ldebian/libpfs-1.2-0/usr/lib/
+       octave3.0-depends -poctave-pfstools
        dh_gencontrol
        dh_md5sums
        dh_builddeb