Code

Removed debian/pfsglview.1.
[pkg-pfstools.git] / debian / rules
index c8284308545666c3c5b23d6a99dfd751bcfbccdb..035a37a734f4c4a312d9cedaf966b10053186fe3 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for pfstools
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -20,8 +20,9 @@ else
 endif
 
 include /usr/share/octave/debian/defs.make
+include /usr/share/dpatch/dpatch.make
 
-config.status: configure
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
        for file in config.guess config.sub; do \
@@ -47,7 +48,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp 
@@ -72,10 +73,10 @@ install: build
        
        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
        
-       chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
+       chmod 644 debian/tmp/$(MDIR)/pfstools/*
        
        # these binaries are not available
-       rm debian/tmp/usr/share/man/man1/pfs{in,out}jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
 
 binary-indep: build install
        # nothing to do here
@@ -84,12 +85,20 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs ChangeLog
-       dh_installdocs AUTHORS README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs -A AUTHORS
        dh_installexamples
        dh_install --sourcedir=debian/tmp --list-missing
-       dh_installman debian/pfsglview.1
+       # these files have been installed twice
+       rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
+               debian/pfstools/usr/share/man/man1/pfsv.1 \
+               debian/pfstools/usr/share/man/man1/pfs*view.1
+       dh_installman
        dh_link
-       dh_strip
+       dh_strip --dbg-package=pfstools-dbg
+       # mkoctfile removes any symbol table and relocation information from the
+       # .oct files making them unusable for the -dbg package
+       rm -rf debian/pfstools-dbg/usr/lib/debug/usr/lib/octave/
        dh_compress -X.pdf
        dh_fixperms
        dh_makeshlibs