Code

Removed a bashism from debian/rules.
[pkg-pfstools.git] / debian / rules
index 62dcad08387c60c6c9748552054ee3a777b487af..027f1c23421b10a1c7b76a69028b435692f7de83 100755 (executable)
@@ -75,7 +75,7 @@ install: build
        chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
        
        # these binaries are not available
-       rm debian/tmp/usr/share/man/man1/pfs{in,out}jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
 
 binary-indep: build install
        # nothing to do here
@@ -89,8 +89,11 @@ binary-arch: build install
        dh_install --sourcedir=debian/tmp --list-missing
        dh_installman debian/pfsglview.1
        dh_link
-       dh_strip
-       dh_compress
+       dh_strip --dbg-package=pfstools-dbg
+       # mkoctfile removes any symbol table and relocation information from the
+       # .oct files making them unusable for the -dbg package
+       rm -rf debian/pfstools-dbg/usr/lib/debug/usr/lib/octave/
+       dh_compress -X.pdf
        dh_fixperms
        dh_makeshlibs
        dh_installdeb