Code

rules: Actually pass CFLAGS to configure.
[pkg-mlmmj.git] / debian / rules
index 53d7e50c96269a6b4189aa5c630990b6dc070cb1..7e5cac52f16e61ec9e9d0e7b60cbbd3e8e26788d 100755 (executable)
@@ -21,7 +21,7 @@ else
 endif
 
 
-export CFLAGS = -Wall -g
+CFLAGS = -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
@@ -31,7 +31,7 @@ endif
 
 config.status: configure patch-stamp
        dh_testdir
-       ./configure $(confflags)
+       ./configure $(confflags) CFLAGS="$(CFLAGS)"
 
 build: build-stamp