Code

Override embedded-javascript-library lintian warning.
[pkg-libmpdclient.git] / debian / rules
index b7cf0d49ed789e378404d8b1d566034540e8092e..efa37f06387a75cade4f161412e87f3df3f2959b 100755 (executable)
@@ -11,7 +11,9 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,22 +21,33 @@ else
        CFLAGS += -O2
 endif
 
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
 config.status: configure
        dh_testdir
+       dh_autotools-dev_updateconfig
        
        ./configure \
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
-                       CFLAGS="$(CFLAGS)"
+                       CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)"
+
+build: build-arch build-indep
 
-build: build-stamp
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
@@ -45,6 +58,7 @@ clean:
        
        [ ! -f Makefile ] || $(MAKE) distclean
        
+       dh_autotools-dev_restoreconfig
        dh_clean
 
 install: build
@@ -66,12 +80,13 @@ install: build
        rm -f debian/tmp/usr/share/doc/libmpdclient/NEWS
        
        dh_install --sourcedir=debian/tmp --fail-missing
+       dh_lintian
 
 binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs -i NEWS
-       dh_installdocs -i AUTHORS
+       dh_installdocs -i -A AUTHORS
        dh_compress -i
        dh_fixperms -i
        dh_installdeb -i
@@ -83,12 +98,12 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs -a NEWS
-       dh_installdocs -a AUTHORS
+       dh_installdocs -a -A AUTHORS
        dh_link -a
        dh_strip -a --dbg-package=libmpdclient2-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -V 'libmpdclient2 (>= 2.2)'
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a