Code

Pass a multiarch --libdir to ./configure.
[pkg-libmpdclient.git] / debian / rules
index efa37f06387a75cade4f161412e87f3df3f2959b..63702e50a81fbc5d92cc7b959acaced880dccfdb 100755 (executable)
@@ -8,8 +8,7 @@
 
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+include /usr/share/dpkg/architecture.mk
 
 CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
@@ -36,6 +35,7 @@ config.status: configure
                        --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
+                       --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
                        CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)"
 
 build: build-arch build-indep
@@ -70,7 +70,7 @@ install: build
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        # we do not want .la files in Debian
-       rm -f debian/tmp/usr/lib/libmpdclient.la
+       rm -f debian/tmp/usr/lib/*/libmpdclient.la
        
        # these files do not include any useful content
        rm -f debian/tmp/usr/share/doc/libmpdclient/README