Code

Pass a multiarch --libdir to ./configure.
[pkg-libmpdclient.git] / debian / rules
index 4be60df5141411f879f9c1da16bd462a5781a552..63702e50a81fbc5d92cc7b959acaced880dccfdb 100755 (executable)
@@ -8,8 +8,7 @@
 
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+include /usr/share/dpkg/architecture.mk
 
 CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
@@ -29,12 +28,14 @@ endif
 
 config.status: configure
        dh_testdir
+       dh_autotools-dev_updateconfig
        
        ./configure \
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
+                       --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
                        CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)"
 
 build: build-arch build-indep
@@ -57,6 +58,7 @@ clean:
        
        [ ! -f Makefile ] || $(MAKE) distclean
        
+       dh_autotools-dev_restoreconfig
        dh_clean
 
 install: build
@@ -68,7 +70,7 @@ install: build
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        # we do not want .la files in Debian
-       rm -f debian/tmp/usr/lib/libmpdclient.la
+       rm -f debian/tmp/usr/lib/*/libmpdclient.la
        
        # these files do not include any useful content
        rm -f debian/tmp/usr/share/doc/libmpdclient/README
@@ -78,6 +80,7 @@ install: build
        rm -f debian/tmp/usr/share/doc/libmpdclient/NEWS
        
        dh_install --sourcedir=debian/tmp --fail-missing
+       dh_lintian
 
 binary-indep: build install
        dh_testdir