Code

copyright: Updated for 2.9.
[pkg-libmpdclient.git] / debian / rules
index 79ee1bcb3be5ec68c2a2260df44128328e565e1f..2418ad8848fd9d1955914cc4badf59ab63ec8055 100755 (executable)
@@ -19,6 +19,12 @@ else
        CFLAGS += -O2
 endif
 
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
 config.status: configure
        dh_testdir
        
@@ -35,6 +41,7 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
@@ -88,7 +95,7 @@ binary-arch: build install
        dh_strip -a --dbg-package=libmpdclient2-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -V 'libmpdclient2 (>= 2.2)'
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a