Code

Patch before configuring and make sure the autotools are not called again.
[pkg-fusedav.git] / debian / rules
index 01227dca4d6617e1133765f7700f201d9f5e00d3..428c5ec80f42e0d3929952962784d31281a4ddcd 100755 (executable)
@@ -23,9 +23,10 @@ endif
 
 include /usr/share/dpatch/dpatch.make
 
-$(BUILDDIR)/config.status: configure
+$(BUILDDIR)/config.status: configure patch
        dh_testdir
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
+       touch aclocal.m4 configure Makefile.in
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \
@@ -33,7 +34,7 @@ $(BUILDDIR)/config.status: configure
 
 build: build-stamp
 
-build-stamp: $(BUILDDIR)/config.status patch
+build-stamp: $(BUILDDIR)/config.status
        dh_testdir
        
        $(MAKE) -C $(BUILDDIR)