Code

git: remove $Id$ svn cruft
[fusedav.git] / src / Makefile.am
index 0221fc5eea0d9d19d5b76463ec5a5954e12ee3a4..df69654d49840e9f004628b50565b154e7c26dd8 100644 (file)
@@ -1,28 +1,31 @@
-# $Id$
-
-# This file is part of fusedav.
+# Copyright (c) 2004-2006 Lennart Poettering
 #
-# fusedav is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation files
+# (the "Software"), to deal in the Software without restriction,
+# including without limitation the rights to use, copy, modify, merge,
+# publish, distribute, sublicense, and/or sell copies of the Software,
+# and to permit persons to whom the Software is furnished to do so,
+# subject to the following conditions:
 #
-# fusedav is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
 #
-# You should have received a copy of the GNU General Public License
-# along with fusedav; if not, write to the Free Software Foundation,
-# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
 
 bin_PROGRAMS=fusedav
 
 fusedav_SOURCES=fusedav.c fusedav.h \
                                statcache.c statcache.h \
                                filecache.c filecache.h \
-                               session.c session.h \
-                               openssl-thread.c openssl-thread.h
+                               session.c session.h
 
-fusedav_CFLAGS = $(AM_CFLAGS) -D_GNU_SOURCE $ 
+fusedav_CFLAGS = $(AM_CFLAGS) $(NEON_CFLAGS) $(FUSE_CFLAGS) -DFUSE_USE_VERSION=25
 fusedav_LDADD = -lpthread $(NEON_LIBS) $(FUSE_LIBS)