Code

Added pChart classes and GOsa mapping class to enable auto-include
[gosa.git] / gosa-core / redhat / gosa.spec
index 8b4236bd03c3ddb48241cbcb9722774f08593d60..cb555cd716c523cdd8bad0442c442108c75eb5f8 100644 (file)
@@ -11,7 +11,7 @@
 #
 Summary:               Web Based LDAP Administration Program 
 Name:                  gosa
-Version:               2.6.1
+Version:               2.6.8
 Release:               1
 License:               GPL
 Source:                ftp://oss.GONICUS.de/pub/gosa/%{sourcename}.tar.bz2
@@ -25,9 +25,9 @@ Patch1:                       02_fix_class_mapping.patch
 Patch2:                        03_fix_locale_location.patch
 Patch3:                        04_fix_online_help_location.patch
 %if %{suse}
-Requires:              apache2,apache2-mod_php5,php5,php5-gd,php5-ldap,php5-mcrypt,php5-mysql,php5-imap,php5-iconv,php5-hash,php5-mbstring,php5-gettext,ImageMagick,gettext-tools
+Requires:              apache2,apache2-mod_php5,php5,php5-gd,php5-ldap,php5-mcrypt,php5-mysql,php5-imap,php5-iconv,php5-hash,php5-posix,php5-mbstring,php5-gettext,ImageMagick,gettext-tools
 %else
-Requires:              httpd,php,php-ldap,php-imap,php-snmp,php-mysql,php-mbstring,ImageMagick,php-mhash,perl-Crypt-SmbHash
+Requires:              httpd,php,php-ldap,php-imap,php-snmp,php-mysql,php-mbstring,ImageMagick,perl-Crypt-SmbHash
 %endif
 BuildRoot:             %{_tmppath}/%{name}-%{version}-root
 BuildArch:             noarch
@@ -257,7 +257,17 @@ do
 done
 
 %if %{suse}
-       sed -i 's#/usr/bin/php#/usr/bin/php5#' %{buildroot}/usr/bin/update-gosa
+       sed -i 's#/usr/bin/php#/usr/bin/php5#' %{buildroot}/usr/sbin/update-gosa
+       sed -i 's#/usr/bin/php#/usr/bin/php5#' %{buildroot}/usr/sbin/gosa-encrypt-passwords
+       cat <<-EOF >> %{buildroot}%{webconf}/gosa-apache.conf
+       
+       <Directory /usr/share/gosa/html>
+           Options None
+           AllowOverride None
+           Order deny,allow
+           Allow from all
+       </Directory>
+       EOF
 %endif
 
 # Copy manpages
@@ -307,12 +317,12 @@ rm -rf %{buildroot}
 %config(noreplace) %attr(0644,root,root) %{webconf}/gosa-apache.conf
 %attr(0700, %{apacheuser}, %{apachegroup}) /var/spool/gosa
 %attr(0755, root,root) /usr/share/gosa
-%attr(0755, root,root) /usr/share/gosa/html
-%attr(0755, root,root) /usr/share/gosa/ihtml
-%attr(0755, root,root) /usr/share/gosa/include
-%attr(0755, root,root) /usr/share/gosa/locale
-%attr(0755, root,root) /usr/share/gosa/plugins
-%attr(0755, root,root) /usr/share/gosa/setup
+#%attr(0755, root,root) /usr/share/gosa/html
+#%attr(0755, root,root) /usr/share/gosa/ihtml
+#%attr(0755, root,root) /usr/share/gosa/include
+#%attr(0755, root,root) /usr/share/gosa/locale
+#%attr(0755, root,root) /usr/share/gosa/plugins
+#%attr(0755, root,root) /usr/share/gosa/setup
 %attr(0755, root,root) /usr/share/gosa/doc/core/guide.xml
 %attr(0755, root,root) /var/cache/gosa
 %attr(0700, root,root) /etc/gosa/gosa.secrets