Code

Fixed ldap->cd [which has no affect, because cd("..") is never used inside GOsa]...
[gosa.git] / gosa-core / debian / rules
index 41f93570ba96aa5fdf503a710974f0060305028e..cc4af94a7eac61149475206a80cbf1f2ff1f6f10 100755 (executable)
@@ -24,6 +24,7 @@ build: patch build-indep
         #*                please stand by                *
         #*************************************************
 
+
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp 
        touch $@
@@ -51,15 +52,20 @@ install-indep:
 binary-common:
        dh_testdir
        dh_testroot
+       install -D -m 644 debian/gosa.lintian-overrides debian/gosa/usr/share/lintian/overrides/gosa
        dh_installchangelogs Changelog
        dh_installdocs
        dh_installexamples
        dh_installmenu
        dh_installdebconf       
-       dh_installman -pgosa-desktop contrib/gosa.1
-       dh_installman -pgosa contrib/gosa.conf.5
+       dh_installman
+       rm -rf debian/gosa/usr/share/gosa/include/smarty
        dh_strip
-       dh_compress -Xgosa.conf 
+       dh_desktop
+       dh_compress
+       # This is an ugly workaround to preserve gosa.conf from beeing compressed. Excluding it
+       # above does not work, because the manual page will match the expression, too.
+       gzip -d debian/gosa/usr/share/doc/gosa/gosa.conf.gz
        dh_fixperms
        dh_installdeb
        dh_gencontrol
@@ -75,4 +81,6 @@ binary-indep: build-indep install-indep
        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 
 binary: binary-indep
+
+binary-arch:
 .PHONY: build clean binary-indep binary install install-indep configure