Code

Updated graph handling
[gosa.git] / gosa-core / debian / rules
index 31b76695d20673a474ffba95a8e89decebd01f2c..cc4af94a7eac61149475206a80cbf1f2ff1f6f10 100755 (executable)
@@ -24,6 +24,7 @@ build: patch build-indep
         #*                please stand by                *
         #*************************************************
 
+
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp 
        touch $@
@@ -46,29 +47,27 @@ install-indep:
        dh_testroot
        dh_clean -k -i 
        dh_installdirs -i
-
-       # Add here commands to install the indep part of the package into
-       # debian/<package>-doc.
-       #INSTALLDOC#
-
-       dh_install -i
+       dh_install -i --exclude COPYING
 
 binary-common:
        dh_testdir
        dh_testroot
+       install -D -m 644 debian/gosa.lintian-overrides debian/gosa/usr/share/lintian/overrides/gosa
        dh_installchangelogs Changelog
        dh_installdocs
        dh_installexamples
        dh_installmenu
        dh_installdebconf       
-       dh_installman -pgosa-desktop contrib/scripts/gosa.1
-       dh_link
+       dh_installman
+       rm -rf debian/gosa/usr/share/gosa/include/smarty
        dh_strip
-       dh_compress 
+       dh_desktop
+       dh_compress
+       # This is an ugly workaround to preserve gosa.conf from beeing compressed. Excluding it
+       # above does not work, because the manual page will match the expression, too.
+       gzip -d debian/gosa/usr/share/doc/gosa/gosa.conf.gz
        dh_fixperms
-       dh_makeshlibs
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
@@ -82,4 +81,6 @@ binary-indep: build-indep install-indep
        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 
 binary: binary-indep
+
+binary-arch:
 .PHONY: build clean binary-indep binary install install-indep configure