Code

Added logging of IP address
[gosa.git] / gosa-core / debian / rules
index 1a7621c961c5039d88033d487d88d1f321685b5e..5a9b10e923599548f0f3adb7e698ad455d79e417 100755 (executable)
@@ -1,116 +1,9 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets  by Bill Allombert 2001
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+       dh $@
 
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
+override_dh_compress:
+       dh_compress
+       gzip -d debian/gosa/usr/share/doc/gosa/gosa.conf.gz
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-#Architecture 
-build: patch build-arch build-indep
-        #*************************************************
-        #* Building GOsa into a Debian/GNU Linux Package *
-        #*                 please stand by               *
-        #*************************************************
-
-build-arch: build-arch-stamp
-build-arch-stamp: configure-stamp 
-
-       # Add here commands to compile the arch part of the package.
-       #$(MAKE) 
-       touch $@
-
-build-indep: build-indep-stamp
-build-indep-stamp: configure-stamp 
-
-       touch $@
-
-clean: clean-patched unpatch
-clean-patched:
-       dh_testdir
-       dh_testroot
-       rm -f build-arch-stamp build-indep-stamp configure-stamp
-
-       dh_clean
-
-unpatch:
-       dpatch deapply-all
-       rm -rf patch-stamp debian/patched
-
-install: install-indep install-arch
-install-indep:
-       dh_testdir
-       dh_testroot
-       dh_clean -k -i 
-       dh_installdirs -i
-
-       # Add here commands to install the indep part of the package into
-       # debian/<package>-doc.
-       #INSTALLDOC#
-
-       dh_install -i
-
-install-arch:
-       dh_testdir
-       dh_testroot
-       dh_clean -k -s 
-       dh_installdirs -s
-
-       dh_install -s
-
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs Changelog
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installdebconf       
-       dh_installman -pgosa-desktop gosa.1
-       dh_link
-       dh_strip
-       dh_compress 
-       dh_fixperms
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-patch: patch-stamp
-patch-stamp:
-       dpatch apply-all
-       dpatch cat-all >patch-stamp
-
-# Build architecture independant packages using the common target.
-binary-indep: build-indep install-indep
-       $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
-
-# Build architecture dependant packages using the common target.
-binary-arch: build-arch install-arch
-       $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
-
-binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure