Code

control, rules, patches/: Removed dpatch support.
[pkg-pfstools.git] / debian / rules
index df6bacf06592194cfbc16a8038304356cbfaf74a..4a38121a2cec376b0b7941e9037402d85ab1875a 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for pfstools
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -21,6 +21,20 @@ endif
 
 include /usr/share/octave/debian/defs.make
 
+confflags = --host=$(DEB_HOST_GNU_TYPE) \
+                       --build=$(DEB_BUILD_GNU_TYPE) \
+                       --prefix=/usr \
+                       --mandir=\$${prefix}/share/man \
+                       --with-moc=moc-qt3 \
+                       --with-octave-m-dir=$(MDIR)/pfstools \
+                       --with-octave-oct-dir=$(OCTDIR)/pfstools
+
+# Matlab is not available in Debian.
+confflags += --disable-matlab
+
+# These libraries are not available / unusable in Debian.
+confflags += --disable-jpeghdr --disable-gdal
+
 config.status: configure
        dh_testdir
        
@@ -31,12 +45,7 @@ config.status: configure
                fi \
        done
        
-       CXXFLAGS="$(CXXFLAGS)" ./configure \
-                       --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
-                       --prefix=/usr --mandir=\$${prefix}/share/man \
-                       --with-moc=moc-qt3 \
-                       --with-octave-m-dir=$(MDIR)/pfstools \
-                       --with-octave-oct-dir=$(OCTDIR)/pfstools
+       ./configure $(confflags) CXXFLAGS="$(CXXFLAGS)"
 
 build: build-stamp
 
@@ -72,10 +81,11 @@ install: build
        
        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
        
-       chmod 644 debian/tmp/usr/share/octave/site/api-v13/m/pfstools/*
+       chmod 644 debian/tmp/$(MDIR)/pfstools/*
        
        # these binaries are not available
-       rm debian/tmp/usr/share/man/man1/pfs{in,out}jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfs*jpeghdr.1
+       rm debian/tmp/usr/share/man/man1/pfsingdal.1
 
 binary-indep: build install
        # nothing to do here
@@ -84,10 +94,15 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs ChangeLog
-       dh_installdocs AUTHORS README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs README TODO doc/faq.txt doc/pfs_format_spec.pdf
+       dh_installdocs -A AUTHORS
        dh_installexamples
-       dh_install --sourcedir=debian/tmp --list-missing
-       dh_installman debian/pfsglview.1
+       dh_install --sourcedir=debian/tmp --fail-missing
+       # these files have been installed twice by dh_install
+       rm -f debian/pfstools/usr/bin/pfs*view debian/pfstools/usr/bin/pfsv \
+               debian/pfstools/usr/share/man/man1/pfsv.1 \
+               debian/pfstools/usr/share/man/man1/pfs*view.1
+       dh_installman
        dh_link
        dh_strip --dbg-package=pfstools-dbg
        # mkoctfile removes any symbol table and relocation information from the
@@ -98,6 +113,7 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps -Llibpfs-1.2-0 -ldebian/libpfs-1.2-0/usr/lib/
+       octave3.0-depends -poctave-pfstools
        dh_gencontrol
        dh_md5sums
        dh_builddeb