Code

Add smarty package for rendering fields with acl's. Closes: #260.
[gosa.git] / debian / rules
index 7daedf5eaae4199be34a45b34b6ca361bcfedcb2..25b91fcedee80f6d3f8567826f9bde5081e1533c 100755 (executable)
@@ -3,7 +3,6 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Cristoph Lameter.
 
-SARGE_PACKAGE=`cat debian/changelog  | head -n1 | grep sarge`
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
@@ -53,6 +52,8 @@ install-stamp:
        -mkdir -p debian/gosa-help-nl/usr/share/doc/gosa-help-nl
        -gzip -c9 debian/changelog > debian/gosa-help-nl/usr/share/doc/gosa-help-nl/changelog.Debian.gz
        -gzip -c9 Changelog > debian/gosa/usr/share/doc/gosa/changelog.gz
+       -mkdir -p debian/smarty-render/usr/share/doc/smarty-render
+       -gzip -c9 debian/changelog > debian/smarty-render/usr/share/doc/smarty-render/changelog.Debian.gz
        -cp AUTHORS README FAQ doc/README.pptp doc/README.xls-export doc/README.glpi doc/README.nagios doc/README.phpscheduleit doc/README.safemode doc/README.devel doc/README.openxchange debian/gosa/usr/share/doc/gosa/
        -rm debian/gosa/usr/share/gosa/doc/README.ssh
        -rm debian/gosa/usr/share/gosa/README debian/gosa/usr/share/gosa/INSTALL
@@ -88,21 +89,19 @@ install-stamp:
        -cp -R debian/gosa-desktop.desktop debian/gosa-desktop/usr/share/applications/gosa.desktop
        -rm -rf debian/gosa/usr/share/gosa/contrib
        -rm -rf debian/gosa/usr/share/gosa/locale/en
-       -rm -rf debian/gosa/usr/share/gosa/gen_locale.sh
-       -rm -rf debian/gosa/usr/share/gosa/gen_pdf_help.sh
+       -rm -rf debian/gosa/usr/share/gosa/update-locale
+       -rm -rf debian/gosa/usr/share/gosa/update-pdf-help
        -rm -rf debian/gosa/usr/share/gosa/patch-stamp
-       -rm -rf debian/gosa/usr/share/gosa/gen_locale_mo.sh
-       -rm -rf debian/gosa/usr/share/gosa/gen_online_help.sh
-       -rm -rf debian/gosa/usr/share/gosa/gen_function_list.php
-       -rm -rf debian/gosa/usr/share/gosa/update.sh
+       -rm -rf debian/gosa/usr/share/gosa/update-online-help
        -rm -rf debian/gosa/usr/share/doc/gosa/guide*
        sed 's%"CONFIG_TEMPLATE_DIR", "../contrib/"%"CONFIG_TEMPLATE_DIR", "/usr/share/doc/gosa/contrib/"%g' debian/gosa/usr/share/gosa/include/functions.inc > debian/gosa/usr/share/gosa/include/functions.inc.new; \
        mv debian/gosa/usr/share/gosa/include/functions.inc.new debian/gosa/usr/share/gosa/include/functions.inc;
-       -if [ -z "${SARGE_PACKAGE}" ]; then \
-               rm -rf debian/gosa/usr/share/gosa/include/smarty; \
-               sed 's%require("smarty/Smarty.class.php");%require("/usr/share/php/smarty/libs/Smarty.class.php");%g' debian/gosa/usr/share/gosa/include/php_setup.inc > debian/gosa/usr/share/gosa/include/php_setup.inc.new; \
-               mv debian/gosa/usr/share/gosa/include/php_setup.inc.new debian/gosa/usr/share/gosa/include/php_setup.inc; \
-       fi
+       mkdir -p debian/smarty-render/usr/share/php/smarty/libs/plugins
+       cp include/smarty/plugins/block.render.php debian/smarty-render/usr/share/php/smarty/libs/plugins
+       chmod -x debian/smarty-render/usr/share/php/smarty/libs/plugins/*
+       rm -rf debian/gosa/usr/share/gosa/include/smarty; \
+       sed 's%require("smarty/Smarty.class.php");%require("/usr/share/php/smarty/libs/Smarty.class.php");%g' debian/gosa/usr/share/gosa/include/php_setup.inc > debian/gosa/usr/share/gosa/include/php_setup.inc.new; \
+       mv debian/gosa/usr/share/gosa/include/php_setup.inc.new debian/gosa/usr/share/gosa/include/php_setup.inc; \
        install -D -m 644 debian/overrides-lintian debian/gosa/usr/share/lintian/overrides/gosa
        install -D -m 644 debian/overrides-linda debian/gosa/usr/share/linda/overrides/gosa
        touch install-stamp
@@ -133,11 +132,7 @@ binary-indep: install
        cd debian/gosa && find ./etc -type f -print | sed -e 's#^./#/#' > DEBIAN/conffiles
        chmod 644 debian/gosa/DEBIAN/conffiles
 
-       -if [ -z "${SARGE_PACKAGE}" ]; then \
-               dh_gencontrol; \
-       else \
-               dh_gencontrol -- -cdebian/control.sarge; \
-       fi
+       dh_gencontrol
        dh_md5sums
        dh_builddeb