Code

Merge branch 'collectd-3.11' into collectd-4.0
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        4.0.6
4 Release:        0.fc7
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, curl
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
28 %package email
29 Summary:        email-plugin for collectd.
30 Group:          System Environment/Daemons
31 Requires:       collectd = %{version}, spamassassin
32 %description email
33 This plugin collectd data provided by spamassassin.
35 %package mysql
36 Summary:        mysql-module for collectd.
37 Group:          System Environment/Daemons
38 Requires:       collectd = %{version}, mysql
39 %description mysql
40 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
41 called handlers and database traffic.
43 %package sensors
44 Summary:        libsensors-module for collectd.
45 Group:          System Environment/Daemons
46 Requires:       collectd = %{version}, lm_sensors
47 %description sensors
48 This  plugin  for  collectd  provides  querying  of sensors  supported  by
49 lm_sensors.
51 %prep
52 rm -rf $RPM_BUILD_ROOT
53 %setup
55 %build
56 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
57 make
59 %install
60 make install DESTDIR=$RPM_BUILD_ROOT
61 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
63 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
64 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
65 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
66 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
68 %clean
69 rm -rf $RPM_BUILD_ROOT
71 %post
72 /sbin/chkconfig --add collectd
73 /sbin/chkconfig collectd on
75 %preun
76 if [ "$1" = 0 ]; then
77    /sbin/chkconfig collectd off
78    /etc/init.d/collectd stop
79    /sbin/chkconfig --del collectd
80 fi
81 exit 0
83 %postun
84 if [ "$1" -ge 1 ]; then
85     /etc/init.d/collectd restart
86 fi
87 exit 0
89 %files
90 %defattr(-,root,root)
91 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
92 %attr(0644,root,root) %config(noreplace) /etc/collectd.conf
93 %attr(0755,root,root) /etc/rc.d/init.d/collectd
94 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
95 %attr(0755,root,root) %{_sbindir}/collectd
96 %attr(0755,root,root) %{_bindir}/collectd-nagios
97 %attr(0644,root,root) %{_mandir}/man1/*
98 %attr(0644,root,root) %{_mandir}/man5/*
100 %attr(0644,root,root) %{_libdir}/%{name}/apcups.so*
101 %attr(0644,root,root) %{_libdir}/%{name}/apcups.la
103 %attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.so*
104 %attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.la
106 %attr(0644,root,root) %{_libdir}/%{name}/battery.so*
107 %attr(0644,root,root) %{_libdir}/%{name}/battery.la
109 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.so*
110 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.la
112 %attr(0644,root,root) %{_libdir}/%{name}/cpu.so*
113 %attr(0644,root,root) %{_libdir}/%{name}/cpu.la
115 %attr(0644,root,root) %{_libdir}/%{name}/csv.so*
116 %attr(0644,root,root) %{_libdir}/%{name}/csv.la
118 %attr(0644,root,root) %{_libdir}/%{name}/df.so*
119 %attr(0644,root,root) %{_libdir}/%{name}/df.la
121 %attr(0644,root,root) %{_libdir}/%{name}/disk.so*
122 %attr(0644,root,root) %{_libdir}/%{name}/disk.la
124 %attr(0644,root,root) %{_libdir}/%{name}/dns.so*
125 %attr(0644,root,root) %{_libdir}/%{name}/dns.la
127 %attr(0644,root,root) %{_libdir}/%{name}/entropy.so*
128 %attr(0644,root,root) %{_libdir}/%{name}/entropy.la
130 %attr(0644,root,root) %{_libdir}/%{name}/exec.so*
131 %attr(0644,root,root) %{_libdir}/%{name}/exec.la
133 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.so*
134 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.la
136 %attr(0644,root,root) %{_libdir}/%{name}/interface.so*
137 %attr(0644,root,root) %{_libdir}/%{name}/interface.la
139 %attr(0644,root,root) %{_libdir}/%{name}/iptables.so*
140 %attr(0644,root,root) %{_libdir}/%{name}/iptables.la
142 %attr(0644,root,root) %{_libdir}/%{name}/irq.so*
143 %attr(0644,root,root) %{_libdir}/%{name}/irq.la
145 %attr(0644,root,root) %{_libdir}/%{name}/load.so*
146 %attr(0644,root,root) %{_libdir}/%{name}/load.la
148 %attr(0644,root,root) %{_libdir}/%{name}/logfile.so*
149 %attr(0644,root,root) %{_libdir}/%{name}/logfile.la
151 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.so
152 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.la
154 %attr(0644,root,root) %{_libdir}/%{name}/memory.so*
155 %attr(0644,root,root) %{_libdir}/%{name}/memory.la
157 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.so*
158 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.la
160 %attr(0644,root,root) %{_libdir}/%{name}/network.so*
161 %attr(0644,root,root) %{_libdir}/%{name}/network.la
163 %attr(0644,root,root) %{_libdir}/%{name}/nfs.so*
164 %attr(0644,root,root) %{_libdir}/%{name}/nfs.la
166 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.so*
167 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.la
169 %attr(0644,root,root) %{_libdir}/%{name}/nut.so*
170 %attr(0644,root,root) %{_libdir}/%{name}/nut.la
172 %attr(0644,root,root) %{_libdir}/%{name}/perl.so*
173 %attr(0644,root,root) %{_libdir}/%{name}/perl.la
175 %attr(0644,root,root) %{_libdir}/%{name}/ping.so*
176 %attr(0644,root,root) %{_libdir}/%{name}/ping.la
178 %attr(0644,root,root) %{_libdir}/%{name}/processes.so*
179 %attr(0644,root,root) %{_libdir}/%{name}/processes.la
181 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.so*
182 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.la
184 %attr(0644,root,root) %{_libdir}/%{name}/serial.so*
185 %attr(0644,root,root) %{_libdir}/%{name}/serial.la
187 %attr(0644,root,root) %{_libdir}/%{name}/swap.so*
188 %attr(0644,root,root) %{_libdir}/%{name}/swap.la
190 %attr(0644,root,root) %{_libdir}/%{name}/syslog.so*
191 %attr(0644,root,root) %{_libdir}/%{name}/syslog.la
193 %attr(0644,root,root) %{_libdir}/%{name}/tape.so*
194 %attr(0644,root,root) %{_libdir}/%{name}/tape.la
196 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.so*
197 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.la
199 %attr(0644,root,root) %{_libdir}/%{name}/users.so*
200 %attr(0644,root,root) %{_libdir}/%{name}/users.la
202 %attr(0644,root,root) %{_libdir}/%{name}/vserver.so*
203 %attr(0644,root,root) %{_libdir}/%{name}/vserver.la
205 %attr(0644,root,root) %{_libdir}/%{name}/wireless.so*
206 %attr(0644,root,root) %{_libdir}/%{name}/wireless.la
208 %attr(0644,root,root) %{_libdir}/%{name}/types.db
210 %dir /var/lib/collectd
212 %files apache
213 %attr(0644,root,root) %{_libdir}/%{name}/apache.so*
214 %attr(0644,root,root) %{_libdir}/%{name}/apache.la
216 %files email
217 %attr(0644,root,root) %{_libdir}/%{name}/email.so*
218 %attr(0644,root,root) %{_libdir}/%{name}/email.la
220 %files mysql
221 %attr(0644,root,root) %{_libdir}/%{name}/mysql.so*
222 %attr(0644,root,root) %{_libdir}/%{name}/mysql.la
224 %files sensors
225 %attr(0644,root,root) %{_libdir}/%{name}/sensors.so*
226 %attr(0644,root,root) %{_libdir}/%{name}/sensors.la
228 %changelog
229 * Mon Aug 06 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.6
230 - New upstream version
232 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
233 - New major releas
234 - Changes to support 4.0.5 
236 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
237 - fixed spec file to build correctly on fedora core
238 - added improved init.d script to work with chkconfig
239 - added %post and %postun to call chkconfig automatically
241 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
242 - New upstream version
244 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
245 - New upstream version
247 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
248 - New upstream version
250 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
251 - New upstream version
253 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
254 - New upstream version
256 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
257 - New upstream version
259 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
260 - New upstream version
261 - Added the `apache' package.
263 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
264 - New upstream version
266 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
267 - New upstream version
269 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
270 - New upstream version
272 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
273 - Include `tape.so' so the build doesn't terminate because of missing files..
274 - New upstream version
276 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
277 - New upstream version
279 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
280 - New upstream version
281 - Removed the extra `hddtemp' package
283 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
284 - New upstream version
286 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
287 - New upstream version
289 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
290 - New upstream version
291 - Added config file, `collectd.conf(5)', `df.so'
292 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
294 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
295 - New upstream version
297 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
298 - New upstream version
300 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
301 - New upstream version
303 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
304 - New upstream version
305 - Added statement to remove the `*.la' files. This fixes a problem when
306   `Unpackaged files terminate build' is in effect.
307 - Added `processes.so*' to the main package
309 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
310 - New upstream version
311 - Added package `collectd-hddtemp'
313 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
314 - New upstream version
315 - Split the package into `collectd' and `collectd-sensors'
317 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
318 - New upstream version
320 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
321 - New upstream version
323 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
324 - New upstream version
326 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
327 - New upstream version
329 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
330 - New upstream version
332 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
333 - New upstream version
335 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
336 - New upstream version
338 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
339 - New upstream version
341 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
342 - Built on RedHat 7.3