Code

Merge branch 'collectd-4.5' into collectd-4.6
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        4.2.0
4 Release:        1.fc6
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel
10 BuildPrereq:    mysql-devel
11 BuildPrereq:    rrdtool-devel
12 BuildPrereq:    net-snmp-devel
13 Requires:       rrdtool
14 Requires:       perl-Regexp-Common
15 Packager:       Florian octo Forster <octo@verplant.org>
16 Vendor:         Florian octo Forster <octo@verplant.org>
18 %description
19 collectd is a small daemon written in C for performance.  It reads various
20 system  statistics  and updates  RRD files,  creating  them if neccessary.
21 Since the daemon doesn't need to startup every time it wants to update the
22 files it's very fast and easy on the system. Also, the statistics are very
23 fine grained since the files are updated every 10 seconds.
25 %package apache
26 Summary:        apache-plugin for collectd.
27 Group:          System Environment/Daemons
28 Requires:       collectd = %{version}, curl
29 %description apache
30 This plugin collectd data provided by Apache's `mod_status'.
32 %package email
33 Summary:        email-plugin for collectd.
34 Group:          System Environment/Daemons
35 Requires:       collectd = %{version}, spamassassin
36 %description email
37 This plugin collectd data provided by spamassassin.
39 %package mysql
40 Summary:        mysql-module for collectd.
41 Group:          System Environment/Daemons
42 Requires:       collectd = %{version}, mysql
43 %description mysql
44 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
45 called handlers and database traffic.
47 %package sensors
48 Summary:        libsensors-module for collectd.
49 Group:          System Environment/Daemons
50 Requires:       collectd = %{version}, lm_sensors
51 %description sensors
52 This  plugin  for  collectd  provides  querying  of sensors  supported  by
53 lm_sensors.
55 %prep
56 rm -rf $RPM_BUILD_ROOT
57 %setup
59 %build
60 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
61 make
63 %install
64 make install DESTDIR=$RPM_BUILD_ROOT
65 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
66 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
67 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
68 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
69 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
70 cp contrib/collection.conf $RPM_BUILD_ROOT/etc/collection.conf
71 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
73 %clean
74 rm -rf $RPM_BUILD_ROOT
76 %post
77 /sbin/chkconfig --add collectd
78 /sbin/chkconfig collectd on
80 %preun
81 if [ "$1" = 0 ]; then
82    /sbin/chkconfig collectd off
83    /etc/init.d/collectd stop
84    /sbin/chkconfig --del collectd
85 fi
86 exit 0
88 %postun
89 if [ "$1" -ge 1 ]; then
90     /etc/init.d/collectd restart
91 fi
92 exit 0
94 %files
95 %defattr(-,root,root)
96 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
97 %attr(0644,root,root) %config(noreplace) /etc/collectd.conf
98 %attr(0644,root,root) %config(noreplace) /etc/collection.conf
99 %attr(0755,root,root) /etc/rc.d/init.d/collectd
100 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
101 %attr(0755,root,root) %{_sbindir}/collectd
102 %attr(0755,root,root) %{_bindir}/collectd-nagios
103 %attr(0644,root,root) %{_mandir}/man1/*
104 %attr(0644,root,root) %{_mandir}/man5/*
106 %attr(0644,root,root) /usr/lib/perl5/5.8.8/i386-linux-thread-multi/perllocal.pod
107 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/Collectd.pm
108 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/Collectd/Unixsock.pm
109 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Collectd/.packlist
110 %attr(0644,root,root) %{_mandir}/man3/Collectd::Unixsock.3pm.gz
112 %attr(0644,root,root) %{_libdir}/%{name}/apcups.so*
113 %attr(0644,root,root) %{_libdir}/%{name}/apcups.la
115 # FIXME!!!
116 #%attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.so*
117 #%attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.la
119 %attr(0644,root,root) %{_libdir}/%{name}/battery.so*
120 %attr(0644,root,root) %{_libdir}/%{name}/battery.la
122 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.so*
123 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.la
125 %attr(0644,root,root) %{_libdir}/%{name}/cpu.so*
126 %attr(0644,root,root) %{_libdir}/%{name}/cpu.la
128 %attr(0644,root,root) %{_libdir}/%{name}/csv.so*
129 %attr(0644,root,root) %{_libdir}/%{name}/csv.la
131 %attr(0644,root,root) %{_libdir}/%{name}/df.so*
132 %attr(0644,root,root) %{_libdir}/%{name}/df.la
134 %attr(0644,root,root) %{_libdir}/%{name}/disk.so*
135 %attr(0644,root,root) %{_libdir}/%{name}/disk.la
137 %attr(0644,root,root) %{_libdir}/%{name}/dns.so*
138 %attr(0644,root,root) %{_libdir}/%{name}/dns.la
140 %attr(0644,root,root) %{_libdir}/%{name}/entropy.so*
141 %attr(0644,root,root) %{_libdir}/%{name}/entropy.la
143 %attr(0644,root,root) %{_libdir}/%{name}/exec.so*
144 %attr(0644,root,root) %{_libdir}/%{name}/exec.la
146 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.so*
147 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.la
149 %attr(0644,root,root) %{_libdir}/%{name}/interface.so*
150 %attr(0644,root,root) %{_libdir}/%{name}/interface.la
152 %attr(0644,root,root) %{_libdir}/%{name}/iptables.so*
153 %attr(0644,root,root) %{_libdir}/%{name}/iptables.la
155 %attr(0644,root,root) %{_libdir}/%{name}/irq.so*
156 %attr(0644,root,root) %{_libdir}/%{name}/irq.la
158 %attr(0644,root,root) %{_libdir}/%{name}/load.so*
159 %attr(0644,root,root) %{_libdir}/%{name}/load.la
161 %attr(0644,root,root) %{_libdir}/%{name}/logfile.so*
162 %attr(0644,root,root) %{_libdir}/%{name}/logfile.la
164 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.so*
165 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.la
167 %attr(0644,root,root) %{_libdir}/%{name}/memcached.so*
168 %attr(0644,root,root) %{_libdir}/%{name}/memcached.la
170 %attr(0644,root,root) %{_libdir}/%{name}/memory.so*
171 %attr(0644,root,root) %{_libdir}/%{name}/memory.la
173 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.so*
174 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.la
176 %attr(0644,root,root) %{_libdir}/%{name}/network.so*
177 %attr(0644,root,root) %{_libdir}/%{name}/network.la
179 %attr(0644,root,root) %{_libdir}/%{name}/nfs.so*
180 %attr(0644,root,root) %{_libdir}/%{name}/nfs.la
182 %attr(0644,root,root) %{_libdir}/%{name}/nginx.so*
183 %attr(0644,root,root) %{_libdir}/%{name}/nginx.la
185 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.so*
186 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.la
188 # FIXME!!!
189 #%attr(0644,root,root) %{_libdir}/%{name}/nut.so*
190 #%attr(0644,root,root) %{_libdir}/%{name}/nut.la
192 %attr(0644,root,root) %{_libdir}/%{name}/perl.so*
193 %attr(0644,root,root) %{_libdir}/%{name}/perl.la
195 %attr(0644,root,root) %{_libdir}/%{name}/ping.so*
196 %attr(0644,root,root) %{_libdir}/%{name}/ping.la
198 %attr(0644,root,root) %{_libdir}/%{name}/processes.so*
199 %attr(0644,root,root) %{_libdir}/%{name}/processes.la
201 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.so*
202 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.la
204 %attr(0644,root,root) %{_libdir}/%{name}/serial.so*
205 %attr(0644,root,root) %{_libdir}/%{name}/serial.la
207 %attr(0644,root,root) %{_libdir}/%{name}/swap.so*
208 %attr(0644,root,root) %{_libdir}/%{name}/swap.la
210 %attr(0644,root,root) %{_libdir}/%{name}/snmp.so*
211 %attr(0644,root,root) %{_libdir}/%{name}/snmp.la
213 %attr(0644,root,root) %{_libdir}/%{name}/syslog.so*
214 %attr(0644,root,root) %{_libdir}/%{name}/syslog.la
216 # FIXME!!!
217 #%attr(0644,root,root) %{_libdir}/%{name}/tape.so*
218 #%attr(0644,root,root) %{_libdir}/%{name}/tape.la
220 %attr(0644,root,root) %{_libdir}/%{name}/tcpconns.so*
221 %attr(0644,root,root) %{_libdir}/%{name}/tcpconns.la
223 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.so*
224 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.la
226 %attr(0644,root,root) %{_libdir}/%{name}/users.so*
227 %attr(0644,root,root) %{_libdir}/%{name}/users.la
229 %attr(0644,root,root) %{_libdir}/%{name}/vserver.so*
230 %attr(0644,root,root) %{_libdir}/%{name}/vserver.la
232 %attr(0644,root,root) %{_libdir}/%{name}/wireless.so*
233 %attr(0644,root,root) %{_libdir}/%{name}/wireless.la
235 %attr(0644,root,root) %{_datadir}/%{name}/types.db
237 %dir /var/lib/collectd
239 %files apache
240 %attr(0644,root,root) %{_libdir}/%{name}/apache.so*
241 %attr(0644,root,root) %{_libdir}/%{name}/apache.la
243 %files email
244 %attr(0644,root,root) %{_libdir}/%{name}/email.so*
245 %attr(0644,root,root) %{_libdir}/%{name}/email.la
247 %files mysql
248 %attr(0644,root,root) %{_libdir}/%{name}/mysql.so*
249 %attr(0644,root,root) %{_libdir}/%{name}/mysql.la
251 %files sensors
252 %attr(0644,root,root) %{_libdir}/%{name}/sensors.so*
253 %attr(0644,root,root) %{_libdir}/%{name}/sensors.la
255 %changelog
256 * Wed Oct 31 2007 Iain Lea <iain@bricbrac.de> 4.2.0
257 - New major release
258 - Changes to support 4.2.0 (ie. contrib/collection.conf)
260 * Mon Aug 06 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.6
261 - New upstream version
263 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
264 - New major release
265 - Changes to support 4.0.5 
267 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
268 - fixed spec file to build correctly on fedora core
269 - added improved init.d script to work with chkconfig
270 - added %post and %postun to call chkconfig automatically
272 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
273 - New upstream version
275 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
276 - New upstream version
278 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
279 - New upstream version
281 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
282 - New upstream version
284 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
285 - New upstream version
287 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
288 - New upstream version
290 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
291 - New upstream version
292 - Added the `apache' package.
294 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
295 - New upstream version
297 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
298 - New upstream version
300 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
301 - New upstream version
303 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
304 - Include `tape.so' so the build doesn't terminate because of missing files..
305 - New upstream version
307 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
308 - New upstream version
310 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
311 - New upstream version
312 - Removed the extra `hddtemp' package
314 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
315 - New upstream version
317 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
318 - New upstream version
320 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
321 - New upstream version
322 - Added config file, `collectd.conf(5)', `df.so'
323 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
325 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
326 - New upstream version
328 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
329 - New upstream version
331 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
332 - New upstream version
334 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
335 - New upstream version
336 - Added statement to remove the `*.la' files. This fixes a problem when
337   `Unpackaged files terminate build' is in effect.
338 - Added `processes.so*' to the main package
340 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
341 - New upstream version
342 - Added package `collectd-hddtemp'
344 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
345 - New upstream version
346 - Split the package into `collectd' and `collectd-sensors'
348 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
349 - New upstream version
351 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
352 - New upstream version
354 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
355 - New upstream version
357 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
358 - New upstream version
360 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
361 - New upstream version
363 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
364 - New upstream version
366 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
367 - New upstream version
369 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
370 - New upstream version
372 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
373 - Built on RedHat 7.3